SolidFire and HCI

SolidFire HCI vSphere RDM configuration with LUN ID's

arnoldromeijn

My lun's from the SolidFire storage are assigned LUN ID 0 in vSphere using iSCSI.

When using RDM's to create disks for a SQL cluster, the RDM's cannot be added to the second node.

Error:Incompatible device backing specified for device ‘0

See https://kb.vmware.com/s/article/2054897

Is there a way to make this work?

2 REPLIES 2

Ontapforrum

I haven't worked with SolidFire but looks like it's a well known error on the VMware blogs.

 

Some pointers :

https://cormachogan.com/2013/04/08/microsoft-clustering-on-vsphere-incompatible-device-errors/


https://kb.vmware.com/s/article/2054897 (workaround)
1) While adding hard disk to additional nodes of cluster, instead of selecting Existing Hard Disk under New device drop-down menu, select RDM Disk under New device drop-down menu and click Add.
2) Select the LUN naaid which was added to the first node of the cluster. The LUN number may be different on this host.
3) Verify that disk got added successfully.

 

https://communities.vmware.com/thread/544475

arnoldromeijn

I tried the VMware workaround. That did not work also.

We setup vvols and were able to add these as shared disks to the Windows cluster.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public