SolidFire and HCI

Start-SFVolumeRestore - S3 backup - no Manifest option

RenaudTouillet

Hello,

 

I'm trying to script backup and restore of SF Volumes to/from S3 storage.

 

Backup is fine.

 

But restore command (Start-SFVolumeRestore) seems to be not complete. On the Web interface we can specify the Manifest Path to select the restore source. But with the PS command, there's no "-manifest" option. How can we specify the manifest path then?

 

I'm using SF PS 1.5.0.119

 

Many thanks.

 

Renaud

1 ACCEPTED SOLUTION

elementx
Start-SFVolumeRestore -VolumeID $ID -RestoreFrom S3 ... -Bucket backups

 

New issue has been created in the SF PowerShell repo:

https://github.com/solidfire/PowerShell/issues/51

View solution in original post

3 REPLIES 3

elementx
Start-SFVolumeRestore -VolumeID $ID -RestoreFrom S3 ... -Bucket backups

 

New issue has been created in the SF PowerShell repo:

https://github.com/solidfire/PowerShell/issues/51

View solution in original post

elementx

The entire process of SolidFire Backup to and Restore from S3, is described here:

 

https://scaleoutsean.github.io/2021/04/21/solidfire-backup-to-s3.html#restore-using-the-api-or-powershell

 

It includes API and PowerShell examples. Tested with SolidFire 12.2, StorageGRID 11.4.

RenaudTouillet

Hello Elementx,

 

This is not correct. -Bucket does exist! This is the -Manifest whitch doesn't exist.

 

Thanks.

 

Renaud

 

 

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public