-
VDDK Is No Longer Available. NetApp’s Shift Toolkit Never Needed It
Over the past week, I've received several messages from customers asking the same question: Does the removal of public VDDK downloads affect NetApp Shift Toolkit migrations? It's a valid concern. Many migration solutions in the market have historically relied on VMware's Virtual Disk Development Kit (VDDK) as a core…
-
SVM Connected NetApp ONTAP Powershell Toolkit, Get-NcVol returns 403 Errors when QoS policy applied
Troubleshooting: enabled PSTK debugging * ERROR DataONTAP.C.PowerShell.SDK.NcRestInterface - The remote server returned an error: (403) Forbidden. * ONTAP does not allow the QoS commands to be assigned to any role at the SVM level – so can’t fix this by adding a permission * Although ZAPI works, dropping back to using ZAPI…
-
NetApp PowerShell Toolkit 9.12.1.2302 / "New-NcVol" -language parameter broken/not working
Hello *, after upgrading NetApp PSTK to latest version 9.12.1.2302 on our win 2012R2 script host and running some dr scripts i noticed a possible error/bug in "New-NcVol" command. When using the parameter -language PS runs the new new-ncvol command without any errors but no volume will be created. I tried every possible…
-
Failing Connect-NcController Command
Hello, I am setting up a new 2022 Windows server to run PowerShell scripts on NetApp. I installed the latest version of the PowerShell Toolkit [9.18.1.2601] and am running a few basic commands to test. Running Import-Module NetApp.ONTAP seems to work fine. However, when I run Connect-NcController, I get the following…
-
NetApp Shift Discovery Error EDSCGMTP002
We have been using NetApp Shift to convert our VMs from VMware to Hyper-V. I am now starting on our second group of hosts running through a different vcenter server. And it will not do a discovery of that cluster. It will discover the VMs, then fail on Discovering volumes and mapping to VMs. We have a primary and a…
-
First cmdlet always fails with limited role.
I'm trying to abide by the Least Privilege model and create a role that only has the privileges needed to run a PowerShell script I plan to run that has these cmdlets: * Connect-NcController * Get-NcFile * new-ncsymlink * add-nccifssymlink * Remove-NcCifsSymlink * Remove-NcFile I have figured out that the…
-
Feature Request: FIPS-Compliant SSH Support in NetApp ONTAP PowerShell Toolkit
I would like to submit a feature enhancement request regarding the NetApp ONTAP PowerShell Toolkit. In our environment, Windows FIPS mode is enabled (“System cryptography: Use FIPS compliant algorithms for encryption, hashing, and signing”). Under this configuration, the Invoke-NcSSH cmdlet fails because the underlying SSH…
-
NetApp SANtricity (E-Series) for hyper cluster
Hello, We have a NetApp SANtricity (E-Series) array and are planning to use it as storage for a Hyper-V cluster (Windows Server). * Has anyone implemented this setup before? * What are your experiences regarding performance and stability? * Are there any best practices or pitfalls to be aware of (iSCSI, MPIO, CSV, etc.)? I…
-
Get-NcVol missing volumes in PowerShell 7
Hi everyone. I'm fairly new to PowerShell. I was tasked with verifying all of our scripts run in PowerShell 7. Currently they are running in PowerShell 5. When used in PowerShell 5, the Get-NcVol command works perfectly, but in PowerShell 7 it misses nearly all of our volumes. I installed the latest version of NetApp…
-
Custom role with Remove-NcSnapshot returning error 403, but still deletes snapshots
I created a new role that should only have snapshot permissions to volumes ending with _stg: security login role create -role stg-admin -vserver dc -cmddirname "volume" -access readonly security login role create -role stg-admin -vserver dc -cmddirname "vserver" -access readonly security login role create -role stg-admin…