Subscribe

Snapcreator OSSV Jobs won't run anymore after upgrade from 4.0p1 to 4.1.2

[ Edited ]

Hello Together,

 

after upgrading SnapCreator from version 4.0p1 to Version 4.1.2 all OSSV Jobs won't run anymore. In the OutLogs we receive the following errors.

 

########## OSSV Backup ##########
[2016-03-30 19:00:59,739] INFO: Getting snapvault status
[2016-03-30 19:01:13,786] INFO: Executing ossv snapvault status: "C:\Programme\netapp\snapvault//bin/snapvault" status
[2016-03-30 19:01:14,040] INFO: Executing command ["C:\Programme\netapp\snapvault//bin/snapvault" status]
[2016-03-30 19:01:14,040] INFO: Command ["C:\Programme\netapp\snapvault//bin/snapvault" status] finished with
exit code: [0]
stdout: [Snapvault primary is ON
Source Destination State Lag Status
TRFILE01:C:\ rt-zrh-dss-301:/vol/ossv_v_tvn_trfile01/C Source 02:54:26 Idle
TRFILE01:SystemState rt-zrh-dss-301:/vol/ossv_v_tvn_trfile01/SystemState Source 02:53:36 Idle
TRFILE01:E:\ rt-zrh-dss-301:/vol/ossv_v_tvn_trfile01/E Source 02:54:04 Idle
TRFILE01:F:\ rt-zrh-dss-301:/vol/ossv_v_tvn_trfile01/F Source 02:53:51 Idle
]
stderr: []
[2016-03-30 19:01:14,040] INFO: Command ["C:\Programme\netapp\snapvault//bin/snapvault" status] finished successfully with message
[Snapvault primary is ON
Source Destination State Lag Status
TRFILE01:C:\ rt-zrh-dss-301:/vol/ossv_v_tvn_trfile01/C Source 02:54:26 Idle
TRFILE01:SystemState rt-zrh-dss-301:/vol/ossv_v_tvn_trfile01/SystemState Source 02:53:36 Idle
TRFILE01:E:\ rt-zrh-dss-301:/vol/ossv_v_tvn_trfile01/E Source 02:54:04 Idle
TRFILE01:F:\ rt-zrh-dss-301:/vol/ossv_v_tvn_trfile01/F Source 02:53:51 Idle
]
[2016-03-30 19:01:14,126] ERROR: Task: ossvSnapVault with config:TVN@TRFILE01_OSSV failed
java.lang.NullPointerException: null
at com.netapp.snapcreator.workflow.task.OssvSnapVault.containsVolume(OssvSnapVault.java:463) ~[workflow.jar:na]
at com.netapp.snapcreator.workflow.task.OssvSnapVault.removeInvalidVolumes(OssvSnapVault.java:437) ~[workflow.jar:na]
at com.netapp.snapcreator.workflow.task.OssvSnapVault.execute(OssvSnapVault.java:94) ~[workflow.jar:na]
at com.netapp.snapcreator.workflow.impl.SCTaskCallableBlocking.call(SCTaskCallableBlocking.java:49) [workflow.jar:na]
at com.netapp.snapcreator.workflow.impl.SCTaskCallableBlocking.call(SCTaskCallableBlocking.java:18) [workflow.jar:na]
at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source) [na:1.7.0_09]
at java.util.concurrent.FutureTask.run(Unknown Source) [na:1.7.0_09]
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [na:1.7.0_09]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [na:1.7.0_09]
at java.lang.Thread.run(Unknown Source) [na:1.7.0_09]
########## Application not defined. Skipping Unquiesce task ##########
########## Agent Workflow Finalization ##########
[2016-03-30 19:01:14,991] INFO: Agent Workflow Finalization started
[2016-03-30 19:01:16,744] INFO: Agent Workflow Finalization finished successfully

 

All other SnapCreator Backup Jobs, SMSQL, MAXDB, Snapvault aso. are running like before, only OSSV Jobs have these Problems. Please find the conf file, out and debug log and the Server Log attached. We would be glad if someone could help us with this problem. 

 

Best Regards

 

Daniel

Re: Snapcreator OSSV Jobs won't run anymore after upgrade from 4.0p1 to 4.1.2

Hello Together,

 

we opened the case 2006232240, but would appreaciate if in the meantime, someone can give us a hint to solve this problem!

 

Best Regards

 

Daniel 

Re: Snapcreator OSSV Jobs won't run anymore after upgrade from 4.0p1 to 4.1.2

Hi during the upgrade procedure did you also upgrade java? With SC 4.1.2 Java Runtime Environment (JRE) 1.6 Update 24 or later must be installed on any Snap Creator Server and Agent host. Then, does the OSSV update work if triggered manually outside SC?

Re: Snapcreator OSSV Jobs won't run anymore after upgrade from 4.0p1 to 4.1.2

[ Edited ]

Hi,

 

no we haven't updatet Java, because we had already a higher version installed.

 

--->

java version "1.7.0_09"
Java(TM) SE Runtime Environment (build 1.7.0_09-b05)
Java HotSpot(TM) 64-Bit Server VM (build 23.5-b02, mixed mode)

<---

 

SnapVault Updates of the effected Server work. As Workaround we scheduled the updates directly on the 7-mode Filer. But if possible we want to wen't back to SnapCreator. Do you have any other suggestions?

 

I will attach the agent Logs of two Servers

 

Best Regards


Daniel