Subscribe
Accepted Solution

default inodes / maxfiles calculation

Hi,

I understand that for every 32K of diskspace 1 inode is calculated (by default).

This would result in the following number of inodes per volume:

3 example volumes:

20MB = 20.480KB -> / 32KB = 640 inodes

1GB = 1.048.576KB -> / 32KB = 32.768 inodes

1TB = 1.073.741.824 -> /32KB = 33.554.432 inodes

i have created these 3 volumes with these sizes and get different results:

20MB = 20.480KB -> 1.237 inodes     (16,6KB)

1GB = 1.048.576KB -> 63.700 inodes     (16,5KB)

1TB = 1.073.741.824 -> 31.876.588 inodes     (33,6KB)

Can anyone explain why the netapp defaults are not used when creating these new volumes ?

Thx

default inodes / maxfiles calculation

i am guessing nobody knows? :-(

default inodes / maxfiles calculation

I got the numbers you would expect to see, remember there is always a bit of "fluff" for wafl overhead.  There is a hidden option to change the default inode allocation if I remember, could someone before you have change it to 16k  allocations?  That could be really bad...at a previous employer we had a customer complain untl the inode counts were all changed(down to 4k per inode), then every time they ran an 'ls' the filer would panic because the 'ls' would run out of memory.  The inode table was so big the filer couldn't load it and failed over.

test*> vol create test aggr0 20M

Creation of volume 'test' with size 20m on containing aggregate 'aggr0' has completed.

test*> maxfiles test

Volume test: maximum number of files is currently 566 (100 used).

dc1test001> vol create test2 aggr0 1T

Creation of volume 'test2' with size 1t on containing aggregate 'aggr0' has completed.

dc1test001*> maxfiles test2

Volume test2: maximum number of files is currently 31876689 (100 used).

****1TB maxfiles is known to be broken****  It is capped at the 31.87 million number and must be adjusted manually

http://now.netapp.com/NOW/cgi-bin/bol?Type=Detail&Display=199233

test> vol create test3 aggr0 1g

Creation of volume 'test3' with size 1g on containing aggregate 'aggr0' has completed.

test*> maxfiles test3

Volume test3: maximum number of files is currently 31122 (100 used).

- Scott

default inodes / maxfiles calculation

Cheers Scott = that seems to be the answer i am looking for.

Does anyone know what the hidden option (to change the default inode allocation) is?

Thx

default inodes / maxfiles calculation

Ok, so I just talked to an old co-worker on that issue.  It has to be done in a maintenence mode boot.  He couldn't remember the exact steps and he also noted that NetApp was not keen to support it. 

We were a very large customer and could get things done that should not have been done(things I would not do now)...so I think I would contact NetApp in your situation and follow up to see what steps you need to take to find out how it was changed.

- Scott