Community

Subscribe
Highlighted

FAS2220/HA - fail to configure/use partner interface

Dear colleagues,

I'm trying to configure our 2220/HA to be actually HA

/etc/rc configs are like

#Auto-generated by setup Sun Dec  2 12:59:22 MSK 2012

# modified by marck 20130513 2115

hostname fas2220a

ifgrp create lacp la0a -b ip e0a e0b e0c e0d

ifconfig la0a `hostname`-la0a mediatype auto partner la0b mtusize 9000

ifconfig la0a alias `hostname`-1

ifconfig e0M `hostname`-e0M partner fas2220b-e0M mtusize 1500

route add 192.168.192.0/24 192.168.136.254 1

routed on

options dns.domainname xxx.domain.tld

options dns.enable on

options nis.enable off

savecore

(and similar for 2220b)

However, after manual cf takeover I do not see neither partner's IPs up nor aggregates/volumes.

ifconfig la0a still reports

fas2220a(takeover)> ifconfig la0a

la0a: flags=0x22fcc863<UP,BROADCAST,RUNNING,MULTICAST,PARTNER_UP,TCPCKSUM> mtu 9000 dad_attempts 2

    inet 192.168.136.220 netmask 0xffffff00 broadcast 192.168.36.255

    inet 192.168.136.221 netmask 0xffffff00 broadcast 192.168.36.255

    inet6 fe80::a0:98ff:fe31:f1fc prefixlen 64 scopeid 0xa autoconf

    partner la0b (not in use)

    ether 02:a0:98:31:f1:fc (Enabled interface groups)

Quick googling does not help; what simple did I miss?

Thanks in advance.

Re: FAS2220/HA - fail to configure/use partner interface

ifconfig _should_ look the same after a takeover - that tells you that the network config came across okay.  You say you don't see either partner's IP - via ping, ifconfig, or what?  You also say you don't see the partner aggregates/volumes - again, how?  aggr/vol status, or trying to mount/map, or ...?

Are the IPs you posted for la0a correct?

Please post both /etc/rc, and both /etc/hosts.

Bill

Re: FAS2220/HA - fail to configure/use partner interface

Actually, I don't exactly know what did I missed, possibly some /etc/hosts records, but right after my post next experiment shown correct failover,

and ifconfig reported:

fas2220a(takeover)> ifconfig la0a

la0a: flags=0x22fec863<UP,BROADCAST,RUNNING,MULTICAST,MULTIHOST,PARTNER_UP,TCPCKSUM> mtu 9000 dad_attempts 2

        inet 192.168.136.220 netmask 0xffffff00 broadcast 192.168.136.255

        inet 192.168.136.221 netmask 0xffffff00 broadcast 192.168.136.255

        inet6 fe80::a0:98ff:fe31:f1fc prefixlen 64 scopeid 0xa autoconf

        partner inet 192.168.136.222 (la0b)

        ether 02:a0:98:31:f1:fc (Enabled interface groups)

Test iSCSI target does handed over correctly both in auto takeover and in manual giveback.

Thank you.