Subscribe

Problem with autoboot

Hello,

After power on or "reboot" command, filer (fas2040) does not boot automatically - we have to run command "autoboot" from loader . Do you have any idea what could be causing this problem? We know about "set autoboot" command, but I guess autoboot should start automatically if we execute "reboot". It is new clustered system, DOT 8.1 (newest), one mk14 shelf with SATA disks and internal SAS disks.

Thank you and best regards,

Rozle

Re: Problem with autoboot

Try resetting environment to default - “set-defaults” in loader prompt and then “boot_ontap”.

Re: Problem with autoboot

Hi,

Looks like a recent cock-up at the factory - have you seen this thread: https://communities.netapp.com/message/80646#80646?

Regards,

Radek

Re: Problem with autoboot

Not sure why all 2040s are coming out this way. Hopefully a TSB posts or support gets this. Please open a case too to report the issue so support knows.

After the set-defaults it might not stay persistent without the bye or saveenv so I would type bye after to power cycle test. Then also would test a halt and power cycle to make sure autoboot is working.

Re: Problem with autoboot

Actually my experience is exactly other way round - “bye” would initiate hardware reset that wipes out current environment settings while “boot_ontap” makes the persistent. I think there was KB on this but cannot find it right now. Do you have any pointers on difference between “bye” and “boot_ontap”?

Re: Problem with autoboot

I had an issue after set-defaults and remember having to type bye for it to take. Although might have been the update-flash. I would test a full power cycle after biotin either way though to make sure the env change is persistent.

Sent from my iPhone 4S

Re: Problem with autoboot

Re: Problem with autoboot

I hadn't seen this issue running bye before but the kb says it clear only for older cfe prompts. I'll have to find the Fas3200 kb which came out when the bootarg wipe clean variable was set. Might have been a tsb. But it had a bye command after setenv changes.

Sent from my iPhone 4S

Re: Problem with autoboot

It was a TSB and it did say “bye”. It is not the first time we see controversial information ☺ I do not have any spare filer where I could test it.

Re: Problem with autoboot

I've seen, or heard about, this on a couple of different models.  The issue is the autoboot environment variable is being set to false in the factory.  The way to check is to go to the LOADER prompt and type:  printenv

Look for the autoboot variable.  If it is set to 'false' then type: setenv autoboot true.   You need to do this to both nodes in an HA pair.

The explanation I was given is if the factory thinks the system will be running Cluster-Mode then they turn autoboot off.  Haven't been able to confirm this, but changing the variable does resolve the issue.