Subscribe

SMHV error

A SMHV job that was running successfully started to fail about 10 days ago. This is on a stand-alone (non-clustered) Hyper-V server (w2k8 R2). The job is a daily backup of the 8-9 vms running on the hyper-v host.

I've tried to research the error but haven't been able to find anything. Is anyone familiar with the error/issue?

Thanks in advance.

Writer Microsoft Hyper-V VSS Writer involved in backup or restore operation is in failed state. Writer returned failure code 0x800423f4. Writer state is 5

Re: SMHV error

Please check the Hyper-V VMMS event log (in the event viewer under “Application and Service Logs->Microsoft->Windows->Hyper-V-VMMS->Admin) to see if there are any errors.

Thanks,

Anagha

SMHV error

I should have mentioned that there are errors in that log. On the day the job started to fail there are errors (16060) at around 5am that the vms on the server were paused because the volume on which the vhds are housed ran out of space. Space was added to the volume and the vms restarted. At around 6pm - which is when the job starts - there are errors (10137) that "no snapshots to revert were found for virtual machine '<VM name here>' (Virtual machine ID <GUID here>). There are nine of these errors (corresponding for the 9 vms) for a few days at the time the job starts (6pm) and then the errors stop.

After that there are only two errors and they are from the same day the above errors stopped and about two hours later:

(ID 19010)

The WMI provider 'Msvm_ServicingSettings.Version' is not registered in the CIM repository.

(ID 14096)
Virtual Machine Management service failed to start.

NOTE: The above service started soon after and is running ok 

Thanks

Re: SMHV error

One of the reasons for “no snapshots to revert…” error is that the automatic mounting of volumes is disabled on Hyper-V host. It can be enabled using MOUNTVOL /E command. You may want to check this setting.

Once there is sufficient space on volumes and Hyper-V VMMS service is running fine, Backups should work (provided auto mount is enabled).

Thanks,

Anagha