Subscribe
Accepted Solution

add-NaNetVlan problem (OnTap 8.0.2)

Has anybody see the following error and know if it is a bug in the powershell api (v1.5) ?

Calling Add-NaNetVlan call, from a powershell script, as follows :

add-NaNetVlan -Interface netvif01 -vlans 607

Add-NaNetVlan : Missing element (in typedef=vlan-info): gvrp-enabled

At E:\pshell\netappB.ps1:81 char:15

+     add-NaNetVlan <<<<  -Interface $vifNameBase -Vlans $vlan

    + CategoryInfo          : InvalidOperation: (xxxxxxxx:NaController) [Add-NaNetVlan], EAPIERROR

    + FullyQualifiedErrorId : ApiException,DataONTAP.PowerShell.SDK.Cmdlets.Net.AddNaNetVlan

This same caled worked under OnTap 7.3.6 using the same powershell api version, 1.5.

add-NaNetVlan problem (OnTap 8.0.2)

Have you recently updated Data ONTAP?  The network cmdlets only work with Data ONTAP 7.3.x.  Support for those APIs will come in a later 8.x release, but currently they are not compatible with any 8.x controllers.   If your still using Data ONTAP 7.3.6.. then I think you found a bug.  we'll look into it, but please report back any additional information.


Hope that helps,

~Glenn

add-NaNetVlan problem (OnTap 8.0.2)

I know...and it's killing me that I have to use the Invoke-NaSsh commandlet to do all of my network interaction with all of my controllers. I need Ontap 8 network support!!!

Re: add-NaNetVlan problem (OnTap 8.0.2)

The good news is that the recently released Data ONTAP 8.0.2 includes the network APIs that were missing from 8.0.1.  The APIs are generally backward compatible, but as you pointed out, the net-vlan-create API definition was changed to make the gvrp-enabled field mandatory, so whether or not the change was intentional, we'll have to update the PowerShell Toolkit accordingly.  We plan to re-test all of the network cmdlets with 8.0.2 during the current development cycle.

add-NaNetVlan problem (OnTap 8.0.2)

It is a recent update to OnTap 8.0.2.

I have a test script the creates a large number of vfilers, ipsapces, vlans etc.

I was testing upgrades and downgrades from 7.3.x to 8.0.2 and back again as the comapany I work for has a very large NetApp estate at differing versions of OnTap.

I needed to run a test on a large number of vfilers etc on the 8.0.2 variant and ran the same script - hence the error.

Many thanks for the replys and I await the newer version with the fixes.

Re: add-NaNetVlan problem (OnTap 8.0.2)

This problem has now been fixed in the powershell api version 1.6