Subscribe

NFS mount at boot - RHEL/CentOS/Oracle - long delay

[ Edited ]

Hi guys,

 

i just seen on sme of our server a strange behaviour, when the server boot (trying to mount 2 FS on a fas2050a) it takes long time (about 60-120 secs).

that is not a big problem (i can delay mysql startup) but id like to understand more.

 

this is my entries in fstab:

netapp:/vol/mysqldata/02 /db02/data nfs _netdev,hard,rw,rsize=65535,wsize=65535,bg,vers=3,tcp,actimeo=600,nointr,suid,timeo=600,noatime
netapp:/vol/mysqllog/02 /db02/logs nfs _netdev,hard,rw,rsize=65535,wsize=65535,bg,vers=3,tcp,actimeo=600,nointr,suid,timeo=600,noatime

 

when the boot process is going look to be ok, but if i login just after sshd is running, i dont see the filesystems mounted, doing a ps -aux i can see 2

processes mount.nfs netapp:........... etc etc

 

so it looks like to nfs mount take long time...

 

any idea ?

 

best regards,

Luca

Re: NFS mount at boot - RHEL/CentOS/Oracle - long delay

Hi Luca,

we normally mount the nfs with the fg instead of bg and it works correctly.

We use those options to mount oracle CRS fs in NFS and they works correctly.

What version of rhel are you using? Are they virtual machine or physical server?

Re: NFS mount at boot - RHEL/CentOS/Oracle - long delay

Hi Francesco,

the options are more or less the same, its a rhel5.7 and it's a physical server actually. yes, probably fg will fix the problem, i haven't thougth about that, i simply applied the suggest options by netapp.

i guess using fg (that is the default) should fix (in this case the mount process should not fork and wait the nfs server to complete the operation)

thanks Francesco, i will let you know

cheers,

Luca

Re: NFS mount at boot - RHEL/CentOS/Oracle - long delay

Hi Francesco,

the problem it's not the mount option fg or bg, but changing it let me found the root cause...

it's a network problem (configuration)

thanks

Luca

Re: NFS mount at boot - RHEL/CentOS/Oracle - long delay

Francesco,

i found the problem, when the server boot and try to bring up the bond0 and bond1 interfaces, those interfaces do not became operational before 20-30 seconds.

using the fg options on the mount, i got a no route to host. removing the bonding and using a single eth interface it works fine.

do you know something about that ? i haven't found nothing on google

Luca

Re: NFS mount at boot - RHEL/CentOS/Oracle - long delay

Hi Luca, normally 20-30 seconds is the time that is needed by spanning tree to adjust the configuration and make the ports active.

You can ask to network admin to set the spanning tree protocol for ports in portfast (at least on cisco switch) or edge (on cisco nexus).

How is the bond configured? It's active passive or lacp ? In the case of simple active-passive you can also optimize probably more disabling other options on the network switches ... i remember that for our private oracle rac network there was a nonegotiate and also another option to let the port become active in a faster way.

Francesco

Re: NFS mount at boot - RHEL/CentOS/Oracle - long delay

Hi Francesco,

i thought about spanning tree, my ports are already in portfast :-( the lacp is configured in active mode... and the bond on linux is mode 4 miimon 100

i dont know how much time is right to spend on this... a sleep 120 in the mysqld script of a good workaround (used with a bg option on the mount)

cheers

Luca