Community

Subscribe
Highlighted
Accepted Solution

Can't add a cluster

I just installed OCUM 6.1 and I am trying to add some clusters.  I added the first one without a problem, but when I tried to install the second one it complained that the self signed certificate had expired.  Sure enough I logged on to the cluster and the certificate was expired.  I used the following command to create a new certificate:

security certificate create -vserver add-n1-nas2 -common-name add-n1-nas2.cert -expire-days 365 -type server

Unfortunately I still received the error that the certificate was expired.  I figured it was still using the older certificate so I deleted the old one.  Apparently that was a mistake, because now OCUM is simply stating "Cannot establish communication to the host <IP> over SSL".  I tried disabling and enabling the "portal" and "ontapi" web services, (hoping that would restart the web server) all to no avail.

Anyone have any ideas what is going on?  And/or what to look at to figure this out?

Thanks,

Keith

Re: Can't add a cluster

Hi Keith Cantrell,

Welcome to communities.

Clustered dataontap ssl certificate regeneration procedure is KB'ed here.

https://kb.netapp.com/support/index?page=content&id=S:1014389&actp=LIST&showDraft=true

Please follow exact steps mentioned here.

Do let us know if the above KB isn't helping

-Srinivas

Re: Can't add a cluster

Yes, thank you!  Following the idea of the KB resolved the issue.  I said "Following the idea" because I assume those instructions were written for 8.1 because they are slightly different for 8.2.  Regardless, it pointed out that I had to enable the "ssl service" after I removed the certificate.

Thanks!

Re: Can't add a cluster

Am glad that you are able to add cluster to ocum 6.1 now.

i will ask the kb team to update the kb article for 8.2 as well.

Thank you for the feedback.

-Srinivas.