Subscribe

DFM 4.0 - turning off an unwanted alert. "Enough Free Space"

Hi all,

I am hoping someone can tell me how to stop this alert from happening. We are not interested in knowing that there is "sufficient free space remaining" on the DFM server. We only want to know if the server is running out of sufficient space and we are successfully getting DFM alerts when this happens. We are using DFM 4.0

So can anyone tell me how to stop getting email alerts about this particular threshold (listed below)?

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Subject: dfm: Normal event on UPPSTSMU002 (Management Station: Enough Free Space)

A Normal event at 11 Jul 08:32 AUS Eastern Standard Time on Mgmt Station UPPSTSMU002:

The file system containing D:/Program Files/NetApp/DataFabric Manager/DFM/data/ has sufficient (13.7 GB or 10.0%) free space remaining for the DataFabric Manager server.

*** Event details follow.***

General Information

-------------------

DataFabric Manager Serial Number: 1-50-010105 Alarm Identifier: 0

Event Fields

-------------

Event Identifier: 35691

Event Name: Management Station: Enough Free Space Event Description: Free disk space needed by the DataFabric Manager server Event Severity: Normal Event Timestamp: 11 Jul 08:32

Source of Event

---------------

Source Identifier: 1

Source Name: UPPSTSMU002

Source Type: Mgmt Station

Source Status: Error

Event Arguments

---------------

dfmFreeSpacePath: D:/Program Files/NetApp/DataFabric Manager/DFM/data/

dfmFreeSpacePercent: 10.02

dfmFreeSpacePercentThresh: 10

dfmFreeSpaceBytes: 1.47069e+010

dfmFreeSpaceBytesThresh: 10000

dfmFreeSpaceDbFileSize: 198295552

dfmFreeSpaceFilesysLimit: 0

dfmFreeSpaceObject: DataFabric Manager server

--NetApp DataFabric Manager

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

C:\Users\sanadmin>dfm event detail 35691

eventAcked

eventAckedBy

eventApplication

eventArguments           dfmFreeSpacePath=D:/Program Files/NetApp/DataFabric Manager/DFM/data/&dfmFreeSpacePercent=10.02&dfmFreeSpaceP

dfmFreeSpaceBytes=1.47069e+010&dfmFreeSpaceBytesThresh=10000&dfmFreeSpaceDbFileSize=198295552&dfmFreeSpaceFilesysLimit=0&dfmFreeSpaceO

Manager server

eventCondition           13.7 GB (10.02%) free space

eventDeleted

eventDeletedBy

eventDescription         Management Station: Enough Free Space

eventDupCount

eventId                  35691

eventNotified            2011-07-11 08:32:39.000000

eventReset               2011-07-11 08:32:39.000000

eventSeverity            Normal

eventSourceId            1

eventSourceTable         0

eventStatus              enough

eventTimestamp           2011-07-11 08:32:39.000000

eventType                dfm.free.space

objComment

objCreationTimestamp     2008-07-01 11:22:00.000000

objDeleted

objDeletedBy

objDisappearedSince

objFlags                 0

objFullName              UPPSTSMU002

objId                    1

objName                  UPPSTSMU002

objPerfStatus            Unknown

objPerfStatusCode        5

objStaleSince

objStatus                Warning

objStatusChangeTimestamp 2011-07-11 08:33:16.000000

objStatusCode            6

objStatusMessage

objStatusTimestamp       2011-07-11 08:33:16.000000

objType                  Mgmt Station

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Let me know if i have not given enough info.

Thanks in Adavnce.

Re: DFM 4.0 - turning off an unwanted alert. "Enough Free Space"

Hi,

Looks like you have configured alarms to notify you for all types of events.

If you are interested only in erroneous conditions, change your alarm configuration and have only warning & above as your severity.

Example :

# dfm alarm create -v warning -E a@b.com

Created alarm 1 with 1 email recipient.

# dfm alarm list 1

Alarm 1

Group Global

Event Severity Warning or Worse

Event Name All

Email Addresses a@b.com

#

Also, can you paste your dfm alarm list command’s output?

Regards

Pradeep L

Re: DFM 4.0 - turning off an unwanted alert. "Enough Free Space"

Thanks Pradeepl,

Alarms list is copied below:


C:\>dfm alarm list
Alarm                1
Group                Global
Event Severity       Critical or Worse
Event Name           All
Email Recipients     whapuku
Email Addresses     xxxxx

Alarm                2
Group                Global
Event Severity       Information or Worse
Event Name           All
Time From            00:00
Time To              23:59
Email Recipients     whapuku
Email Addresses     xxxx

Alarm                3
Group                EBkPk/PROD v1 SCHOOLS - Ultimo SQL volumes
Event Severity       All
Event Name           volume-autosized
Time From            00:00
Time To              23:59
Email Recipients     whapuku
Email Addresses      xxxxx


I may have inadvertently turned this on by creating Alarm #3. I am trying to get an email alert sent when volumes auto-grow. This is because my Production SQL LUNs are in volumes that are set to grow automatically if they reach their pre-defined threshold. If the SQL volumes needs to autogrow then i would like to be alerted, investigate why and if required increase the size of the volumes.
However my attempt to get this alert through has failed so far. If I "test" the alarm i do get a test email, however the SNMP trap does not seem to be sent from the filers to the admin host where DFM resides (which should trigger the email alert). I receive other email alerts for other events just fine.
I have created a test volume and added it to the Group in the Alarm (#3). I have then enabled the "vol autosize" function on this volume and then filled the volume up with data files. When the volume reaches its capacity threshold I can see a message on the filer console that the volumes does indeed autogrow but am not receiving the email alert about it.


Can you advise how to get this eamil alert working (and turn the benign one off)?

Regards
WH

DFM 4.0 - turning off an unwanted alert. "Enough Free Space"

Hi,

If you are getting " management-station:not-enough-free-space" event and you are resolving the condition(say by deleting any unwanted files ) then  "Management Station: Enough Free Space" event will

follow that. This is an expexted behaviour but if you are getting only "Management Station: Enough Free Space" event repeatedly,then let us know.

For the volume-autosized event,we will work on it in the lab and update you on the same.

Re: DFM 4.0 - turning off an unwanted alert. "Enough Free Space"

Hi Pradeepl,

I can confirm that we are receiving the "Management-Station:not-enough-free-space" event alert and when space is freed up (either by the processes running on the management server or by ourselves) we receive the "Management Station: Enough Free Space" event alert.

The thing is we only started getting the "Management Station: Enough Free Space" alert recently and do not want to know when there is enough free space (because we are flooded with email alerts as it is). We have always received the "Management-Station:not-enough-free-space" alert when free space fell below 10% of disk space and If repeated within a short space of time then we know there is an issue and look to resolve it.

We have recently upgraded our filers to DataOntap 8.0.1 and therefore installed the DFM plugin for 8.0.1. Could this be the reason we are suddenly seeing these alert emails?

Thanks again.

WH

Re: DFM 4.0 - turning off an unwanted alert. "Enough Free Space"

Hi,

Upgrading of filers will not be the reason. Can you give us the outputs of "dfm report view events 1","dfm report view events-history 1","dfm report view events-history-deleted 1".

Regards

Pradeep L

Re: DFM 4.0 - turning off an unwanted alert. "Enough Free Space"

Hi,

For getting e-mail alert for "vol autosize" event ,please make sure the following steps are done,

Pre-requiste:

Add the DFM as traphost to filer using snmp traphost add <dfm-ip-address>

1)Create an e-mail alert(alarm) for the event " volume-autosized".[You have this with alarm id 3]

2)Create a volume of size say 20MB on ontap and let dfm discover it.Make sure dfm discovered the volume by executing dfm volume list.

Note volume size is only 16MB as 20% goes for snapreserve.

3)Enable autosize for newly created volume by vol autosize <vol> -m <size> on eg: vol autosize vol_autosize -m 25m on

4)Now write data on this volume say write 20MB,

5)Now on filer console you can see meesages like "Wed Jul 13 13:38:31 GMT [wafl.vol.autoSize.done:info]: Automatic increase size of volume 'vol_autosize' by 1024 kbytes done." 4 times.

6)Now DFM will generate the event " volume-autosized" 4 times and send the alarm 4 times .

why 4 times ?

This is because we asked the volume to grow by 5MB(25MB -20MB) ,which means the volume will grow 4MB (80% of 5MB) .The default increment size is 1MB so the volume grows 4 times for 4MB.

Hope now you will get the event .Let me know if you need any more details.

Regards

Pradeep L

Re: DFM 4.0 - turning off an unwanted alert. "Enough Free Space"

Thankyou Pradeep,

I have already done this on the filer and tested (my volume is a little bigger than yours but the steps below are the same as I have already done).

As stated – I do see the message on the filer console telling me that the volume has auto-grown. However I do not see the event in DFM nor get an email alert about it.

Any other ideas.

Kind Regards

Wayne Hapuku

Enterprise Storage Administrator

Information Technology Directorate

Re: DFM 4.0 - turning off an unwanted alert. "Enough Free Space"

Hi Pradeep,

I am leaving my current employer in a just over a week and I was looking for a quick answer to this question. This is pretty low on my list of things to have completed by the time I leave and due to the other priorities that I have I will no longer pursue this question.

I will close the question I had about this alert. Thanks for your help so far though.

Kind Regards

Wayne Hapuku

Enterprise Storage Administrator

Information Technology Directorate

Re: DFM 4.0 - turning off an unwanted alert. "Enough Free Space"

I will start a new discussion on the "Volume Autogrow" event and alert.

Thanks Pradeep.