Subscribe

Date stamp in scheduled report name

[ Edited ]

Hi,

 

There is a requirement to prefix or suffix date stamp on the attached report name. I know we can do that within report, but can't think of a way to use that function outside report studio.

The report is developed and scheduled.

 

For eg report name is "Storage Utilization", but when user receive that in his/her inbox then he/she see the attachment as "Storage Utilization 2017-02-28". And when same report run on 1st March then it should be "Storage Utilization 2017-03-01"

 

Note: I need that on attached report, not in subject line of mail

 

Thanks

Re: Date stamp in scheduled report name

I haven't tried it myself, but the IBM document linked below seems to provide instructions on how to do this. 

 

https://www.ibm.com/support/knowledgecenter/en/SSEP7J_10.2.2/com.ibm.swg.ba.cognos.ug_cra.10.2.2.doc/t_asg_add_timestamp_toname.html

 

Note that after any OCI upgrade, you will need to re-implement the change to Advanced Settings.  These settings are not preserved through OCI upgrades. 

Re: Date stamp in scheduled report name

Hi Moe,

 

I creating followed the steps mentioned in that link. Created optional paramter too to specify the format, but still next day schedule reports don't have date stamp.

 

Link just mentioned about creating new parameter but how it is applicable to attachments? We have not specified any variable anywhere in report name.

And where? I mean it suffix date stamp or preffix. 

 

Would you please test it yourself and see if that is really working?

Re: Date stamp in scheduled report name

I don't have SMTP rigged up in any of my labs, and it may not be practical to do so. 

 

One thing I should have recommended you check, is whether the procedure in the IBM article applies to the version of Cognos running in your version of OCI.  It's possible this is a too-new option. 

Re: Date stamp in scheduled report name

After I upgraded OCI to 7.2.4, my cognos is on same version as mentioned in the link I posted earlier. Still that is not working.

 

Can someone else try the same who have SMTP configured in their environment? or suggest alternative way to achieve this.