Subscribe
Highlighted
Accepted Solution

OCUM 7.0RC1-Invalid links in Email Alert

Two instances of UCUM 7.0RC1 are exhibiting the same behavior.  When an alert is sent to an email, the event details link to https://localhost:443/um/.......(see attachment for screenshot).  I assume "localhost" should have the name of the UCUM or OPM server.    Prior to upgrading from 6.x, when an alert was sent to email, I was able to click on the event details link, which would then connect me to OCUM or OPM, and view the alert.  Any ideas?

 

-Thanks.

Re: OCUM 7.0RC1-Invalid links in Email Alert

I also observed that OCUM registeres in WFA with the localhost address. I had to change the data source in WFA manually afterwards to reflect the right name/IP.

So this seems to be a general problem in 7.0RC1.

 

regards, Niels

Re: OCUM 7.0RC1-Invalid links in Email Alert

Is your setup running in Windows or Linux or vApp?

 

If it is running on Windows or Linux, can you paste the output of following commands:

 

* hostname

* ping <hostname>

* pint -a <ip_address>

 

I do have a workaround for this issue, and the above output would help me to validate that.

 

 

Regards,
Saravanan

Re: OCUM 7.0RC1-Invalid links in Email Alert

It is a vApp.  Will the proposed workaround still work?  If so, please share.

 

-Thanks.

Re: OCUM 7.0RC1-Invalid links in Email Alert

Hello,

 

Do you have a solution for this issue ?

I'm facing the same problem.

Re: OCUM 7.0RC1-Invalid links in Email Alert

Hi PierreC.  I do not have a solution for this.  I am urging my customer to open a ticket.  This has not yet been done.  

 

-Thanks.

Re: OCUM 7.0RC1-Invalid links in Email Alert

same problem here. someone found a solution?

thanks

Re: OCUM 7.0RC1-Invalid links in Email Alert

Hello all,

 

we do have the same issue - even running OCUM 7.0 GA.

 

Risk          - Aggregate Nearly Overcommitted

Impact Area   - Protection

Severity      - Warning

State         - Obsolete

Source        - XX

Trigger Condition - XX

 

Event details:

https://localhost:443/um/#event-details:event-id=401596

 

Source details:

https://localhost:443/um/#aggregate-details:aggregate-id=726

 

Alert details:

https://localhost:443/um/#alerts:alert-id=2001

 

 

 

 

Solution would be very much appreciated!

 

Best regards

Albrecht

Re: OCUM 7.0RC1-Invalid links in Email Alert

Sorry for the delay. Can you please reset the hostname using "um option" command.

 

Steps to fix this problem:

 

* Go to the console (root console)

* Login to "um cli"

* Set the custom.hostname option to the new value for whcih DNS works

* restart the ocie service

 

 

The commands for the above steps are shared below.

 

um cli login -u <user_name> -p <pwd>
um option set custom.hostname=oncommand-71rc1-168.gdl.englab.netapp.com

service ocie restart

 

 

Let me know if that doesnt work.

 

Regards,

Saravanan

Re: OCUM 7.0RC1-Invalid links in Email Alert

[ Edited ]

Thanks - worked for me.

I changed the following options to reflect the actual FQDN rather than "localhost":

 

autosupport.fromAddress
custom.hostname 
email.fromAddress
protection.wfa.um.datasourceName
quotaEmail.format.from    

 

Unfortunately the manual restart of the ocie service did not succeed. I had to restart the vApp but all is fine now.

 

regards, Niels