Subscribe

Performance Advisor no data for 1 filer, status green

Greetings all,

I have a set of 6 filers in Operations Manager / Performance Advisor. All 6 of them show a green light in the "Data Collection Status" column, but 1 of them doesn't actually seem to have any data. all 19 Object Types in the list (nfsv3, disk, etc) show a Used Space of 768 bytes, and the charts/graphs under the View are all blank. The other filers show a Used Space of anywhere from 768 bytes for some object types (presumably, things that don't get used) up to 10MB for others.

I can collect client statistics for it... that seems to work fine. But the main stats/counters seem to have no data. This happens for that filer itself, as well as the aggregates and volumes within it.

Any ideas as to what might be wrong, or where I might look for diagnostic info?

Thanks!

Jake

Performance Advisor no data for 1 filer, status green

Change to the realtime view to see wether there will be some change. And then set back.

Bing

Performance Advisor no data for 1 filer, status green

Nope... no dice. Realtime view shows no data as well. "Storage System Summary View" graphs just have no data plotted on them. Other views like Top Volumes say "No data is currently available for chart".

"dfm host diag" shows that it has snmp connectivity, and I can ssh to the filer from the DFM host as well... so it seems not to be a firewalling issue.

"dfm perf data describe -v system" shows plenty of enabled counters, but the oldest and newest record fields are blank, number of records is zero, and used space is 768 bytes. Max records is 525600.

"dfm perf data retrieve -V "System Basic -d 6000" shows no output... so it's not just a graphing problem, there really seems to be no data to plot.

Any ideas?

Re: Performance Advisor no data for 1 filer, status green

Did you ever figure this out?   I'm having the same issue...

Re: Performance Advisor no data for 1 filer, status green

Not sure why this is, but I would start by going into the Operation Manager GUI, select the physical filer (eg Member Details -> Physical Systems -> filer), then select 'Diagnose Connectivity'.  Check everything looks OK there, in particular at the end under 'Performance Advisor Checklist'

Re: Performance Advisor no data for 1 filer, status green

Connectivity looks fine:

Performance Advisor Checklist

 

perfAdvisorEnabled Passed
hostType Passed
hostRevision Passed
hostLogin Passed
perfAdvisorTransport Passed

All the other DFM data (volume capacity, aggregates, etc) is being collected, alerting works fine, protection manager works.  Its only the performance data that doesnt seem to be collecting.  You can see that the counters are enabled, but they dont contain any records, as the previous poster said.

Re: Performance Advisor no data for 1 filer, status green

did you get anywhere with this? I ahve the same issue. Everything is enabled, everything looks fine but for some reason it's not collecting the volume stats for some filers. It seems to collecting everything else ok

File Name:           perf_68_73677_169

Number Records:      0

Sample Rate:         1.0 minutes

Max Records:         43200

Used Space:          768 bytes

Max Projected Space: 2.29 GB

Oldest Record:

Newest Record:

Enabled Counters:

      avg_latency

      cifs_latency

      cifs_ops

      cifs_other_latency

.....

etc

Re: Performance Advisor no data for 1 filer, status green

talking to myself, but bumping  options perf.dblade_zapi.buf_limit seems to have fixed the issue. Please check this though http://support.netapp.com/NOW/cgi-bin/bol?Type=Detail&Display=472940 as it's potentially dangerous

Re: Performance Advisor no data for 1 filer, status green

I know this is a ghos town, but has anyone solved this? I'm having the same issue.
The bug above is fixed in my ONTAP version.