Subscribe

Topology view in OCI 6.4.3

Hello all,

Out of curiosity, when I am looking at the main Topology view of a Host, should I be able to see all the storage a Host is masked to?  In our view, we can see what the Host is pathed/zoned to (the Green line), but what if the host is masked to another array, but volumes are not mapped or zoned to it (the Blue line).  Should we be able to see the complete topology, or will only the volumes that are actively using the storage show in this view?  I'm not sure if that makes any sense.  Ultimately, we are missing a view to an array for a number of hosts, an array that is both masked/zoned, but it's not showing up in the main Topology view.  I'm also concerned that we might be missing a path outage to that array.

If I do Tools>Analyze Missing Path for one of the volumes, I see in that Topology view the masked/mapped (the Yellow line) to the array that is missing in the main Topology view, and it reports it as a path outage.  Is there a way of populating all of the information in the main Topology view without needing to go to that level of diving?

Thanks!

Re: Topology view in OCI 6.4.3

The host topology is really a reflection of the paths and potentially violations.

So long as the HBAs are identified to the Host, if you go to the Masking microview, you should be able to see all the volumes masked to the host, regardless of whether a path is in existence or not.

It sounds like you may not have path outage violations because the paths were never built by OCI - could there be FC switches out there that have never been discovered by OCI?

Re: Topology view in OCI 6.4.3

We've identified all of the FC switches - we just went through a review to make sure we had everything.  At this point, all we see are the paths that are Green.  Nothing more. 

I can see the volumes in the Masking micro-view. 

I can see that the host is Zoned to that array in the Zone Members micro-view. 

I do not see those volumes in the Volume micro-view.  What is the impact of the Host and Storage ports not sharing the same fabric on the Topology view?

OCI seems to know there is a connection to that array, it just doesn't show up in the main Host Topology view.  And when I went to Tools>Analyze Missing Path, we see the Yellow line for Masked/Mapped to that array, which is not populating in the main Topology view.