Subscribe

Identical FC/FCoE adapter WWN and WWPN on the two nodes in a 2-node netapp simulator cluster

[ Edited ]

Hi, guys,

 

I set up a 2-node netapp cluster-mode cluster using the Netapp OnTAP 8.2.1 Simulator on top of ESXi. Upon finishing setting up the cluster, I used the OnCommand System Manager to check the configurations on the two netapp ontap nodes and found that both nodes have the identical WWN and WWPN for their FC/FCoE adapters. Please see the attached API call output. Well, given that we are reusing the same vmdk file for the second simulator and there's no instruction in the document for updating the HBA adapter settings. Does any one know how to change the WWN and WWPN information on the second simulator node? Any help would be appreciated.

 

Thanks,

Danjue

 

 

python apitest.py 192.168.128.16 admin fixstream123 fcp-adapter-get-iter

 

OUTPUT:

<results status="passed">

    <attributes-list>

        <fcp-config-adapter-info>

            <adapter>0a</adapter>

            <connection-established>ptp</connection-established>

            <data-link-rate>8</data-link-rate>

            <fabric-established>true</fabric-established>

            <fabric-name>50:0a:09:80:80:10:20:00</fabric-name>

            <firmware-rev>1.0.0</firmware-rev>

            <hardware-rev>1.0.0</hardware-rev>

            <info-name>Fibre Channel Target Adapter 0a (ACME Fibre Channel Adapter, rev. 1.0.0, 8G)</info-name>

            <max-speed>8</max-speed>

            <media-type>ptp</media-type>

            <node>netapp-simulator-01</node>

            <node-name>50:0a:09:80:80:10:20:00</node-name>

            <physical-protocol>fibre_channel</physical-protocol>

            <port-address>1000</port-address>

            <port-name>50:0a:09:80:81:10:20:00</port-name>

            <speed>auto</speed>

            <state>online</state>

            <switch-port>ACME Switch:1</switch-port>

        </fcp-config-adapter-info>

        <fcp-config-adapter-info>

            <adapter>0b</adapter>

            <connection-established>ptp</connection-established>

            <data-link-rate>8</data-link-rate>

            <fabric-established>true</fabric-established>

            <fabric-name>50:0a:09:80:80:10:20:01</fabric-name>

            <firmware-rev>1.0.0</firmware-rev>

            <hardware-rev>1.0.0</hardware-rev>

            <info-name>Fibre Channel Target Adapter 0b (ACME Fibre Channel Adapter, rev. 1.0.0, 8G)</info-name>

            <max-speed>8</max-speed>

            <media-type>ptp</media-type>

            <node>netapp-simulator-01</node>

            <node-name>50:0a:09:80:80:10:20:01</node-name>

            <physical-protocol>fibre_channel</physical-protocol>

            <port-address>1001</port-address>

            <port-name>50:0a:09:80:81:10:20:01</port-name>

            <speed>auto</speed>

            <state>online</state>

            <switch-port>ACME Switch:1</switch-port>

        </fcp-config-adapter-info>

        <fcp-config-adapter-info>

            <adapter>0c</adapter>

            <connection-established>ptp</connection-established>

            <data-link-rate>10</data-link-rate>

            <fabric-established>true</fabric-established>

            <fabric-name>50:0a:09:80:80:10:20:02</fabric-name>

            <firmware-rev>1.0.0</firmware-rev>

            <hardware-rev>1.0.0</hardware-rev>

            <info-name>Fibre Channel Target Adapter 0c (ACME Fibre Channel Adapter, rev. 1.0.0, CNA_10G)</info-name>

            <max-speed>10</max-speed>

            <media-type>ptp</media-type>

            <node>netapp-simulator-01</node>

            <node-name>50:0a:09:80:80:10:20:02</node-name>

            <physical-protocol>ethernet</physical-protocol>

            <port-address>1002</port-address>

            <port-name>50:0a:09:80:81:10:20:02</port-name>

            <speed>auto</speed>

            <state>online</state>

            <switch-port>ACME Switch:1</switch-port>

        </fcp-config-adapter-info>

        <fcp-config-adapter-info>

            <adapter>0d</adapter>

            <connection-established>ptp</connection-established>

            <data-link-rate>10</data-link-rate>

            <fabric-established>true</fabric-established>

            <fabric-name>50:0a:09:80:80:10:20:03</fabric-name>

            <firmware-rev>1.0.0</firmware-rev>

            <hardware-rev>1.0.0</hardware-rev>

            <info-name>Fibre Channel Target Adapter 0d (ACME Fibre Channel Adapter, rev. 1.0.0, CNA_10G)</info-name>

            <max-speed>10</max-speed>

            <media-type>ptp</media-type>

            <node>netapp-simulator-01</node>

            <node-name>50:0a:09:80:80:10:20:03</node-name>

            <physical-protocol>ethernet</physical-protocol>

            <port-address>1003</port-address>

            <port-name>50:0a:09:80:81:10:20:03</port-name>

            <speed>auto</speed>

            <state>online</state>

            <switch-port>ACME Switch:1</switch-port>

        </fcp-config-adapter-info>

        <fcp-config-adapter-info>

            <adapter>0e</adapter>

            <connection-established>ptp</connection-established>

            <data-link-rate>16</data-link-rate>

            <fabric-established>true</fabric-established>

            <fabric-name>50:0a:09:80:80:10:20:04</fabric-name>

            <firmware-rev>1.0.0</firmware-rev>

            <hardware-rev>1.0.0</hardware-rev>

            <info-name>Fibre Channel Target Adapter 0e (ACME Fibre Channel Adapter, rev. 1.0.0, 16G)</info-name>

            <max-speed>16</max-speed>

            <media-type>ptp</media-type>

            <node>netapp-simulator-01</node>

            <node-name>50:0a:09:80:80:10:20:04</node-name>

            <physical-protocol>fibre_channel</physical-protocol>

            <port-address>1004</port-address>

            <port-name>50:0a:09:80:81:10:20:04</port-name>

            <speed>auto</speed>

            <state>online</state>

            <switch-port>ACME Switch:1</switch-port>

        </fcp-config-adapter-info>

        <fcp-config-adapter-info>

            <adapter>0a</adapter>

            <connection-established>ptp</connection-established>

            <data-link-rate>8</data-link-rate>

            <fabric-established>true</fabric-established>

            <fabric-name>50:0a:09:80:80:10:20:00</fabric-name>

            <firmware-rev>1.0.0</firmware-rev>

            <hardware-rev>1.0.0</hardware-rev>

            <info-name>Fibre Channel Target Adapter 0a (ACME Fibre Channel Adapter, rev. 1.0.0, 8G)</info-name>

            <max-speed>8</max-speed>

            <media-type>ptp</media-type>

            <node>netapp-simulator-02</node>

            <node-name>50:0a:09:80:80:10:20:00</node-name>

            <physical-protocol>fibre_channel</physical-protocol>

            <port-address>1000</port-address>

            <port-name>50:0a:09:80:81:10:20:00</port-name>

            <speed>auto</speed>

            <state>online</state>

            <switch-port>ACME Switch:1</switch-port>

        </fcp-config-adapter-info>

        <fcp-config-adapter-info>

            <adapter>0b</adapter>

            <connection-established>ptp</connection-established>

            <data-link-rate>8</data-link-rate>

            <fabric-established>true</fabric-established>

            <fabric-name>50:0a:09:80:80:10:20:01</fabric-name>

            <firmware-rev>1.0.0</firmware-rev>

            <hardware-rev>1.0.0</hardware-rev>

            <info-name>Fibre Channel Target Adapter 0b (ACME Fibre Channel Adapter, rev. 1.0.0, 8G)</info-name>

            <max-speed>8</max-speed>

            <media-type>ptp</media-type>

            <node>netapp-simulator-02</node>

            <node-name>50:0a:09:80:80:10:20:01</node-name>

            <physical-protocol>fibre_channel</physical-protocol>

            <port-address>1001</port-address>

            <port-name>50:0a:09:80:81:10:20:01</port-name>

            <speed>auto</speed>

            <state>online</state>

            <switch-port>ACME Switch:1</switch-port>

        </fcp-config-adapter-info>

        <fcp-config-adapter-info>

            <adapter>0c</adapter>

            <connection-established>ptp</connection-established>

            <data-link-rate>10</data-link-rate>

            <fabric-established>true</fabric-established>

            <fabric-name>50:0a:09:80:80:10:20:02</fabric-name>

            <firmware-rev>1.0.0</firmware-rev>

            <hardware-rev>1.0.0</hardware-rev>

            <info-name>Fibre Channel Target Adapter 0c (ACME Fibre Channel Adapter, rev. 1.0.0, CNA_10G)</info-name>

            <max-speed>10</max-speed>

            <media-type>ptp</media-type>

            <node>netapp-simulator-02</node>

            <node-name>50:0a:09:80:80:10:20:02</node-name>

            <physical-protocol>ethernet</physical-protocol>

            <port-address>1002</port-address>

            <port-name>50:0a:09:80:81:10:20:02</port-name>

            <speed>auto</speed>

            <state>online</state>

            <switch-port>ACME Switch:1</switch-port>

        </fcp-config-adapter-info>

        <fcp-config-adapter-info>

            <adapter>0d</adapter>

            <connection-established>loop</connection-established>

            <data-link-rate>0</data-link-rate>

            <fabric-established>false</fabric-established>

            <firmware-rev>1.0.0</firmware-rev>

            <hardware-rev>1.0.0</hardware-rev>

            <info-name>Fibre Channel Target Adapter 0d (ACME Fibre Channel Adapter, rev. 1.0.0, CNA_10G)</info-name>

            <max-speed>10</max-speed>

            <media-type>ptp</media-type>

            <node>netapp-simulator-02</node>

            <node-name>50:0a:09:80:80:10:20:03</node-name>

            <physical-protocol>ethernet</physical-protocol>

            <port-address>0</port-address>

            <port-name>50:0a:09:80:81:10:20:03</port-name>

            <speed>auto</speed>

            <state>offlined by user/system</state>

            <switch-port>ACME Switch:1</switch-port>

        </fcp-config-adapter-info>

        <fcp-config-adapter-info>

            <adapter>0e</adapter>

            <connection-established>ptp</connection-established>

            <data-link-rate>16</data-link-rate>

            <fabric-established>true</fabric-established>

            <fabric-name>50:0a:09:80:80:10:20:04</fabric-name>

            <firmware-rev>1.0.0</firmware-rev>

            <hardware-rev>1.0.0</hardware-rev>

            <info-name>Fibre Channel Target Adapter 0e (ACME Fibre Channel Adapter, rev. 1.0.0, 16G)</info-name>

            <max-speed>16</max-speed>

            <media-type>ptp</media-type>

            <node>netapp-simulator-02</node>

            <node-name>50:0a:09:80:80:10:20:04</node-name>

            <physical-protocol>fibre_channel</physical-protocol>

            <port-address>1004</port-address>

            <port-name>50:0a:09:80:81:10:20:04</port-name>

            <speed>auto</speed>

            <state>online</state>

            <switch-port>ACME Switch:1</switch-port>

        </fcp-config-adapter-info>

    </attributes-list>

    <num-records>10</num-records>

</results>

Re: Identical FC/FCoE adapter WWN and WWPN on the two nodes in a 2-node netapp simulator cluster

You do realize that the simulators do not support FC, right?

Re: Identical FC/FCoE adapter WWN and WWPN on the two nodes in a 2-node netapp simulator cluster

This is how it is done on a physical system, not sure if it will work on the sim:

1. Access the local node on each head (node run local)
2. Go into diag mode (priv set diag)
3. setflag wafl_metadata_visible 1
4. rdfile  /etc/metadir/vdisk/configuration (to make sure the configuration file exists)
5. Force WWN regeneration by removing the configuration file (rm /etc/metadir/vdisk/configuration)
6. Reboot the node (or takeover/giveback)