Subscribe

api-services "Try it out!" link only works on the api-server host

The "Try it out!" link always goes to a URL that specifies the host as "localhost", even when using a browser that is not running on the api-services server. This means that the "Try it out!" link will only work locally, never remotely. In order to try out an API I always have to press the button, let it fail, then paste the URL into another tab and change "localhost" to the hostname of my api-services server. This is getting old very rapidly. Please advise on how to wave the magic wand and fix this.

 

Due to certain considerations, I am still using version 1.1, with hopes to upgrade to 1.2 in the next few weeks.

 

Thank you for your attention to this matter,

    Scott Lindley

Re: api-services "Try it out!" link only works on the api-server host

Hi  ,

 

After successful installation   the installer  displays the link we should use for swagger . Can you please access via IP address instead of the hostname .

Currentky hostname is not supported  and its a known issue .

 

Thanks and Regards

Indushree

Re: api-services "Try it out!" link only works on the api-server host

It didn't help. Connected to the WebUI via the IP instead of the hostname, and "Try it out!" buttons still attempt to connect to "localhost", which of couse only work if the browser is running on the server - not an option where I work. To paraphrase Led Zeppelin - "The behavior remains the same".

 

Thanks anyway,

    Scott Lindley

Re: api-services "Try it out!" link only works on the api-server host

Can we setup webex to  look in to the issue.  We had simillar issue if the interface configuration and hostname settings is not proper .