Subscribe

Moving to vSphere 6, Which VSC to use 5.0 or 6.0

Hi All

 

I am currently upgrading our vSphere 5.0 to vSphere 6.0 however have hit a bit of stumbling block which I am hoping I can get some advice from the community.

 

Our current situation is: New Vsphere vCenter 6.0 with ESXi 5.0.0 U3 hosts. The Hosts will be upgraded shortly to 6.0 however I want to setup VSC first, would I install VSC 6 which I know is vSphere 6 compatible? However the hosts are still on 5.0? Or do I install initially whilst the hosts are on 5, install VSC 5.0?

 

Once the hosts are upgraded to ESXi6, then I look at upgrading the VSC plugin from 5.0 to 6.0?

 

I have looked at the interoperability Matrix tool and there doesnt seem to be an upgrade path for the above? The closest I have found is:

 

Using VSC 5.0 with the Hypervisor we are using (5.0 U3) however the supported vCenter isnt showing 6, the maximum is vCenter 5.5 update 2.

 

Could I get away using VSC 5.0 with vCenter 6 and ESXi 5.0 U3 hosts? The vCenter server is based on Windows 2012 R2 enterprise.

 

The version of Data ONTAP we are using is 8.2.1 7 Mode and our storage is FAS2240-4 and FAS8020.

 

Any advice would be greatly appreciated.

Thanks 

Re: Moving to vSphere 6, Which VSC to use 5.0 or 6.0

I know this topic is relatively old, I hope that you have found answers to your questions by now.  Just in case you haven't...

 

Here is a quick matrix of compatibility between VSC, vCenter, and Data ONTAP versions.  Note that this graphic lumps vCenter and ESXi versions together.

 

reply2_1.png

 

My understanding is that you can install VSC 6.0 with your vCenter 6.0, but VSC will have limited functionality with vSphere 5.0.  Once upgrading to vSphere 5.5+, then you should be fine.

 

Andrew

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Moving to vSphere 6, Which VSC to use 5.0 or 6.0

Thanks 

I have now managed to roll a setup out our vSphere 6  environment since this post which was quite a while. 

 

I installed VSC 6.0 as the last component. We upgraded to v5.0 to v6.0 from fresh and started with a new vcenter install with existing v5.0 hosts, slowly migrated to hosts to ESXi6 using VMware VUM (Update manager) and then as the final piece installed VSC 6.0 and this worked fine.  

Re: Moving to vSphere 6, Which VSC to use 5.0 or 6.0

what about if you want to keep your existing backups/schedules and restores? did you worry about this at all? 

did you follow the KB 1011871 and just upgrade the software and pointed to the new vCenter server for registration?

Re: Moving to vSphere 6, Which VSC to use 5.0 or 6.0

No i lost all those, I didnt even think if there was a way to keep the schedules as our environment isnt large so I recreated them from scratch.