Subscribe
Accepted Solution

SRA not recognizing qtree exports (discoverDevices error)

This seems like it's been done to death in other threads, but I've run out of things to try to get my SRA to see my qtree exports.

vSphere 5.0U1

SRM 5U1

OnTap 8.1.1

SRA v2.x

I have source and destination vFilers with QSM replicating happily within the vFiler context.

Each vol only has one qtree

The qtrees are exported as follows:

exportfs

/vol/acmgoldata01/data  -sec=sys,rw=10.137.107.0/24,root=10.137.107.0/24

/etc/exports reflects exportfs

The qtrees are mounted in ESXi as they are defined in QSM.

NFS only

The confusing part of the error log shows;

-->  hostname_IP_path = 10.137.107.38 - IP_In_System = 10.137.107.38

--> 

--> 15-10-2012T21:06:10   and 10.137.107.38 matched !

--> 15-10-2012T21:06:10  Collecting igroup information

--> 15-10-2012T21:06:10  Could not find an igroup of ostype vmware

--> 15-10-2012T21:06:10  Collecting list of replicated Luns

--> 15-10-2012T21:06:10  Could not discover any Luns mapped to igroup of ostype vmware and replicated

--> 15-10-2012T21:06:10  Collecting list of replicated exports

--> 15-10-2012T21:06:10  Skipping this path /vol/acmsys01 since there are no r/w rules          <--- vFiler root

--> 15-10-2012T21:06:10  Skipping this path /vol/acmgoldata01 since there are no r/w rules       <--- vol containing my qtree

--> 15-10-2012T21:06:10  validating if path /vol/acmgoldata01/data is valid mirrored device for given peerArrayId  <--- my qtree

--> 15-10-2012T21:06:10  checking if path /vol/acmgoldata01/data is reverse replicated 

--> 15-10-2012T21:06:10  validating if path /vol/acmgoldata01/data is valid mirrored device for given peerArrayId

--> 15-10-2012T21:06:10  path /vol/acmgoldata01/data is not reverse replicated

--> 15-10-2012T21:06:10  Including /vol/acmgoldata01/data after checking opaque filters

--> 15-10-2012T21:06:11  Could not discover any replicated exports

--> 15-10-2012T21:06:11  no devices found

--> 15-10-2012T21:06:11  Discover Devices completed with errors

Cheers,

Ham

Re: SRA not recognizing qtree exports (discoverDevices error)

I'm a cabbage.

I set the exportfs and /etc/exports on the physical filer. As soon as I updated the vFiler, it works.

Ham.

Re: SRA not recognizing qtree exports (discoverDevices error)

updating the vFiler maybe has correctly compiled and formatted the /etc/snapmirror.conf file so the SRA starting working with the matching devices on the exports.

Hi guys!

Here we go.

Another question solved is that if you are using NFS datastore mounted as
NetApp QTREE,

i.e.:

123.123.123.101:/vol/volname/qtreename

where 123.123 is the ip address of the Filer and the datastore monted is the
qtreename

remember to include in the volume include list in the GUI of the SRA 2.0
array pairs only the volume name.

but remember also to check the correct presence of the volume in the Filer's
snapmirror.conf.

I mean that if you are using some advanced feature (like NetApp Data Fabric
Manager alias DFM) to implement and make use of the NetApp QTree techmology,
don't worry about the way you have mounted the NFS Datastore on the ESXi
hosts.

Even if you mount the qtree & net the main volume, the SRA will accept
the volume name (i.e. volname) and also the qtree name (qtreename).

We have tried also the two things toghether:

i.e.

imput box of array pair of the SRA:   volname,qtreename

comma separated values.

the enable functions works perfectly....

    

but remember to compile correctly the Filer /etc/exports & the snapmirror.conf

Davide Sitta

Sinergy S.p.A.

Italy