Subscribe
Accepted Solution

VSC shows a blank page in the Virtual center

Hi all

i am new to the site.

I have an issue with VSC.

I am using version 2, and Vphere4 update1.

VSC was working fine, but after a couple of weeks, i just get a blanks page in the Virtual center.

Also i get the below error in the Windows application Avent logs.

Many thanks

Richard

Log Name:      Application
Source:        SMVI
Date:          18/10/2010 15:44:28
Event ID:      4096
Task Category: Error
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      GBCSVVC01.int.elekta.com
Description:
25635 [WrapperSimpleAppMain] ERROR com.netapp.common.server.ServerMain - CLI-01090: CLI failed with the exception "java.net.SocketException: Unrecognized Windows Sockets error: 0: JVM_Bind".
com.netapp.common.server.ServerException: java.net.SocketException: Unrecognized Windows Sockets error: 0: JVM_Bind at com.netapp.common.server.AbstractJettyServer.start(AbstractJettyServer.java:137) at com.netapp.common.server.ServerFacade.start(ServerFacade.java:61) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) at java.lang.reflect.Method.invoke(Unknown Source) at com.netapp.common.cli.binding.CommandBinding.execute(CommandBinding.java:97) at com.netapp.common.server.ServerMain.execute(ServerMain.java:43) at com.netapp.common.server.ServerMain.main(ServerMain.java:68) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) at java.lang.reflect.Method.invoke(Unknown Source) at org.tanukisoftware.wrapper.WrapperSimpleApp.run(WrapperSimpleApp.java:244) at java.lang.Thread.run(Unknown Source)Caused by: java.net.SocketException: Unrecognized Windows Sockets error: 0: JVM_Bind at java.net.PlainSocketImpl.socketBind(Native Method) at java.net.PlainSocketImpl.bind(Unknown Source) at java.net.ServerSocket.bind(Unknown Source) at java.net.ServerSocket.<init>(Unknown Source) at java.net.ServerSocket.<init>(Unknown Source) at javax.net.ssl.SSLServerSocket.<init>(Unknown Source) at com.sun.net.ssl.internal.ssl.SSLServerSocketImpl.<init>(Unknown Source) at com.sun.net.ssl.internal.ssl.SSLServerSocketFactoryImpl.createServerSocket(Unknown Source) at org.mortbay.jetty.security.SslSocketConnector.newServerSocket(SslSocketConnector.java:409) at org.mortbay.jetty.bio.SocketConnector.open(SocketConnector.java:73) at org.mortbay.jetty.AbstractConnector.doStart(AbstractConnector.java:272) at org.mortbay.jetty.bio.SocketConnector.doStart(SocketConnector.java:147) at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:39) at org.mortbay.jetty.Server.doStart(Server.java:233) at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:39) at com.netapp.common.server.AbstractJettyServer.start(AbstractJettyServer.java:125) ... 14 more
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="SMVI" />
    <EventID Qualifiers="0">4096</EventID>
    <Level>2</Level>
    <Task>5</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2010-10-18T14:44:28.000000000Z" />
    <EventRecordID>9912</EventRecordID>
    <Channel>Application</Channel>
    <Computer>xxxxxxxxxxxxxxxx(Blanked out)</Computer>
    <Security />
  </System>
  <EventData>
    <Data>25635 [WrapperSimpleAppMain] ERROR com.netapp.common.server.ServerMain - CLI-01090: CLI failed with the exception "java.net.SocketException: Unrecognized Windows Sockets error: 0: JVM_Bind".
com.netapp.common.server.ServerException: java.net.SocketException: Unrecognized Windows Sockets error: 0: JVM_Bind at com.netapp.common.server.AbstractJettyServer.start(AbstractJettyServer.java:137) at com.netapp.common.server.ServerFacade.start(ServerFacade.java:61) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) at java.lang.reflect.Method.invoke(Unknown Source) at com.netapp.common.cli.binding.CommandBinding.execute(CommandBinding.java:97) at com.netapp.common.server.ServerMain.execute(ServerMain.java:43) at com.netapp.common.server.ServerMain.main(ServerMain.java:68) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) at java.lang.reflect.Method.invoke(Unknown Source) at org.tanukisoftware.wrapper.WrapperSimpleApp.run(WrapperSimpleApp.java:244) at java.lang.Thread.run(Unknown Source)Caused by: java.net.SocketException: Unrecognized Windows Sockets error: 0: JVM_Bind at java.net.PlainSocketImpl.socketBind(Native Method) at java.net.PlainSocketImpl.bind(Unknown Source) at java.net.ServerSocket.bind(Unknown Source) at java.net.ServerSocket.&lt;init&gt;(Unknown Source) at java.net.ServerSocket.&lt;init&gt;(Unknown Source) at javax.net.ssl.SSLServerSocket.&lt;init&gt;(Unknown Source) at com.sun.net.ssl.internal.ssl.SSLServerSocketImpl.&lt;init&gt;(Unknown Source) at com.sun.net.ssl.internal.ssl.SSLServerSocketFactoryImpl.createServerSocket(Unknown Source) at org.mortbay.jetty.security.SslSocketConnector.newServerSocket(SslSocketConnector.java:409) at org.mortbay.jetty.bio.SocketConnector.open(SocketConnector.java:73) at org.mortbay.jetty.AbstractConnector.doStart(AbstractConnector.java:272) at org.mortbay.jetty.bio.SocketConnector.doStart(SocketConnector.java:147) at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:39) at org.mortbay.jetty.Server.doStart(Server.java:233) at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:39) at com.netapp.common.server.AbstractJettyServer.start(AbstractJettyServer.java:125) ... 14 more</Data>
  </EventData>
</Event>

Re: VSC shows a blank page in the Virtual center

Could be a wild guess but I’m wondering if tomcat is having issues. Could you also file a support case for this?

Regards

Amrita

Re: VSC shows a blank page in the Virtual center

Hi

Thanks for replying, Tomcat seems fine. The VC funtions that require Tomcat all work, and Tomcat itself seems good.

Kind regards

Re: VSC shows a blank page in the Virtual center

I had the same issue, In my case the proxy setting in IE was the problem. Maybe another (security?) setting in IE will do the job?

Re: VSC shows a blank page in the Virtual center

Hi Richard

Did you check if there were any password changes to the filer? after the config of VSC??

Re: VSC shows a blank page in the Virtual center

Thanks, that was exactly what the issue was. Very frustrating, when changes are made without a change control process!!!!

Many thanks.

Re: VSC shows a blank page in the Virtual center

@tomas_netherlands: Thanks for the tip! I was wondering why the console didn't work on my machine, but I didn't look at the proxy settings.

-->Removed the proxy and now it works :-)