Subscribe

SC Agent stops responding - service restart needed

[ Edited ]

IHAC using SC to backup Oracle databases on windows.

Every so often - daily - backups stops working and it seems that it's the agent that stops responding/stops accepting connections.

In this case, app quiesce and unquiesce runs for however long the SC timeout value is set to.

We also have seen another issue on the same server where we actually gets a backup session going but the first thing

in the agent log is an error - agt-00006 - meaning the watchdog could not be started, potentially due to resource constraints.

After an agent restart, backups starts working again until the next time it stops working again.

There's no agent log files on the Oracle servers from backup attempts where the session is never setup - guessing that is the reason.

For the agt-00006 errors, well there's obviously an agent log but no details of what could be the issue.

How do I troubleshoot the agent?

Thanks in advance,

Erik Stjerna

Re: SC Agent stops responding - service restart needed

There is an issue with windows service and out agent where we dont get the logs, I am thinking that is the problem. We are working on addressing this but it wont be fixed until SC 4.1.

To troubleshoot you should run agent from command line, dont use service. Simply create a task in windows scheduler to everytime system starts to start the agent. You need to create a .bat script and in that have "C:/path/to/scAgent3.6.0/snapcreator.exe --start-agent 9090 --verbose --debug >C:/tmp/agent_console.out". This should print agent log console info to a logfile. Also make sure in config SC_AGENT_LOG=Y and agent should log under scAgent3.6.0/logs directory.

Another option is simple run agent from console and leave it open "snapcreator.exe --start-agent 9090 --verbose --debug"

Regards,

Keith

Re: SC Agent stops responding - service restart needed

Thanks Keith,

I'll work with the customer and see what we can dig up!

--erik