Subscribe
Accepted Solution

Fas 2040 ISCSI start/license problem

Hi,

Got brand new Fas2040 and License shows that ISCSI is enabled. When I try to start ISCSI START got iscsi: service is not licensed. Entering license got License add: "iscsi" is included and no license code is necessary.

I'm a little bit confused. Any help?

thanks

Benjamin

Re: Fas 2040 ISCSI start/license problem

With support representative we found a solution:

you cannot manage embedded licenses from cli. using system manager I was able to enable iscsi.

Re: Fas 2040 ISCSI start/license problem

you cannot manage embedded licenses from cli

Really? "options licensed_features"

Re: Fas 2040 ISCSI start/license problem

Tried License add and License delete but no dice.

License command shows ISCSI enabled, system manager shows disabled. Once enabled in system manager I was able to start ISCSI.

Didn't try with Options licensed_features....

Re: Fas 2040 ISCSI start/license problem

It's a year later, but I've just encountered this issue myself and tried the CLI options. For the sake of accuracy to the above 'answer', I'm adding my conclusion here.

aborzenkov is correct. You can enable the licensed_feature option, and it will resolve your iSCSI issue without having to resort to System Manager.

> options license

licensed_feature.disk_sanitization.enable off

licensed_feature.fcp.enable off

licensed_feature.flexcache_nfs.enable off

licensed_feature.iscsi.enable off

licensed_feature.multistore.enable off

licensed_feature.vld.enable off

> options licensed_feature.iscsi.enable on

Run 'iscsi start' to start the iSCSI service.

Also run 'lun setup' if necessary to configure LUNs.

> iscsi start

iSCSI service started