Subscribe
Accepted Solution

SMVI - A general system error occurred: Protocol error from VMX

I have an smvi job scheduled daily that fails. I have attached the error log. It looks like SMVI attempts to create the VMware snapshot and fails due to a protocol error from VMX.  Doing a quick search on VMWare forums states its  a problem with a custom quiescing scripts http://communities.vmware.com/message/1016429#1016429- is this a problem with SMVI's script to trigger the VMWare snapshot?

As a side note I can manually create the VMWare snapshot. Also to note there are three smvi snapshots already in snapshot manager that look like they have never been committed. I have attached the .bmp file that shows this. I imagine it could be the error is being thrown due to the existing smvi snapshots present.  Then my question is why is smvi not committing these snapshots?

Re: SMVI - A general system error occurred: Protocol error from VMX

What protocol are you using to connect to the NetApp? NFS or iSCSI/FC? (There's a specific config change for helping with snapshot timeouts if using NFS.)

Also, do you ever have issues with snapshots taken manually through the VI client?

Re: SMVI - A general system error occurred: Protocol error from VMX

If you try a manual VMware snapshot, do not just right click on the VM to take a snapshot. Instead, go to the Scheduled Tasks page and create a new scheduled task to create a snapshot of the VM. Make sure you that check to enable disk consistency and turn off the memory snapshot. You can then schedule it to run just a single time. This will then mirror how SMVI creates a VMware snapshot.

Re: SMVI - A general system error occurred: Protocol error from VMX

Looking at your log file, it only took a few seconds between starting the VMware snapshot creation and when the error was reported.

Are you running VMware Tools in the guest OS? Is it set up to use VSS or the sync driver?

Two tests you could try would be

  1. Disable VMware Tools VSS and sync drivers.
  2. Remove VMware Tools. Shut down the VM (not a restart, but an actual shutdown). Power on VM. Reinstall VMware Tools.

My guess is that either the VSS or sync drivers are causing issues on that VM. Disabling may make the issue go away. Reinstalling VMware Tools may fix the actual issue.

Josh

Re: SMVI - A general system error occurred: Protocol error from VMX

We are using FC to connect to FAS2020.

Most recently I received an error taking a snapshot of a virtual machine with the virtual machine memory option checked.  The error was "A general system error occured: unable to save snapshot file." If I uncheck the snapshot the virtual machine memory option the snapshot works fine.

Re: SMVI - A general system error occurred: Protocol error from VMX

Yes vmware tools is running on this virtual machine.  The file system sync  driver is installed and VSS is not installed. Uninstalling the sync driver and running the job again failed with same error.  I then uninstalled vmware tools and powered off and on the virtual machine and the job ran successfully.  So it looks like the sync driver was the issue although I am not sure why.  I know it is responsilble for freezing and thawing the file system but what would cause it to fail?

Thanks for your assistance.

Re: SMVI - A general system error occurred: Protocol error from VMX

It looks, sounds & smells like the very same problems we have faced recently during SMVI & SnapDrive 6.1 testing - so far support guys didn't come back with nothing more creative than "don't use the sync driver".

Apparently the bug sits on VMware side, so it's up to them to sort this out.

Regards,
Radek

Re: SMVI - A general system error occurred: Protocol error from VMX

I have found a few threads on the VMWare community forums for the same issue (just with VCB/whatever else as the instigator) and the easiest solution is typically to just restart the vmware tools service in the guest.

Re: SMVI - A general system error occurred: Protocol error from VMX

oops - double post