Data Backup and Recovery Discussions

ndmp copy

Rawat_Sunil

Hi,

 

I want to copy dept_test from hq-fas3250-p-1 to  dr-fas3140a in path :/vol/vol_test and ran the below mentioned command but command failed pls suggest

 

 

hq-fas3250-p-1> ndmpcopy -da aa-x-srawat:PASSWORD /vol/dept_test dr-fas3140a:/vol/vol_test

Ndmpcopy: Starting copy [ 17 ] ...

Ndmpcopy: hq-fas3250-p-1: Notify: Connection established

Ndmpcopy: dr-fas3140a: Notify: Connection established

Ndmpcopy: Authentication failed for destination

Ndmpcopy: hq-fas3250-p-1: Connect: Authentication successful

Ndmpcopy: Done

 

 

 

Regards,

 

Sunil Rawat

6 REPLIES 6

notermanjeroen

Hi,

 

The KB "How to use NDMP-based copy utilities (such as ndmpcopy) to copy data between the same or different modes of Data ONTAP" uses:

For 7-Mode:

Step 1: Enable NDMP and set a password on the source and destination storage systems.

  1. Enable NDMP:
    netapp> ndmpd on
  2. Create a new user specifically for NDMP:
    netapp*> useradmin user add ndmp -g "Backup Operators"
    New password: XXXXXXXXX
    Retype new password: XXXXXXXXX
    User <ndmp> added.
  3. Non-root users have a special NDMP password that is different from their login password and is displayed by this command:
    netapp> ndmpd password ndmp
    password MzUV5p6R
  4. Set NDMP to accept both plaintext and md5 authentication requests:
    netapp> options ndmpd.authtype plaintext,challenge

Step 2: Determine the arguments for your NDMP based copy

For 7-Mode:
Authentication Type: Can be encrypted (called challenge or md5) or clear text (called text or clear-text);  md5 / challenge is recommended
Hostname or IP: Hostname or IP address of the storage controller
Path: Path in the format /vol/volume (or /vol/volume/qtree or /vol/volume/qtree/file)

 

If running the Data ONTAP 7-Mode ndmpcopy command
Build a command line:
ndmpcopy -d -sa <source_user>:<source_pass> -st <auth_type> -da <dest_user>:<dest_pass> -dt <auth_type> <hostname_or_IP>:<source_path> <hostname_or_IP>:<dest_path>

Example syntax for a 7-Mode to 7-Mode NDMP-based copy by running the ndmpcopy command:
netapp> ndmpcopy -d -sa ndmp:v0smhhqZ -st md5 -da ndmp:v0smhhqZ -dt md5 10.64.31.43:/vol/chris2/qt2 10.64.31.43:/vol/chris2/qt2-copy

Hope this helps.

Kind regards

Rawat_Sunil

I have checked the destination password which is also right.

 

Able to copy file in same host.

 

but not able to ndmpcopy file to different host

I have tried it. Please find the below output and screenshots.

 

fas02> ndmpcopy -sa root:Netapp1! -da root:Netapp1! fas01:/vol/vol1 fas02:/vol/vol1
Ndmpcopy: Starting copy [ 1 ] ...
Ndmpcopy: fas01: Notify: Connection established
Ndmpcopy: fas02: Notify: Connection established
Ndmpcopy: fas01: Connect: Authentication successful
Ndmpcopy: fas02: Connect: Authentication successful
Ndmpcopy: fas01: Log: DUMP: creating "/vol/vol1/../snapshot_for_backup.1" snapshot.
Ndmpcopy: fas01: Log: DUMP: Using Full Volume Dump
Ndmpcopy: fas01: Log: DUMP: Date of this level 0 dump: Mon Apr 25 10:52:46 2016.
Ndmpcopy: fas01: Log: DUMP: Date of last level 0 dump: the epoch.
Ndmpcopy: fas01: Log: DUMP: Dumping /vol/vol1 to NDMP connection
Ndmpcopy: fas01: Log: DUMP: mapping (Pass I)[regular files]
Ndmpcopy: fas01: Log: DUMP: mapping (Pass II)[directories]
Ndmpcopy: fas01: Log: DUMP: estimated 323 KB.
Ndmpcopy: fas01: Log: DUMP: dumping (Pass III) [directories]
Ndmpcopy: fas01: Log: DUMP: dumping (Pass IV) [regular files]
Ndmpcopy: fas01: Log: ACL_START is '337920'
Ndmpcopy: fas01: Log: DUMP: dumping (Pass V) [ACLs]
Ndmpcopy: fas02: Log: RESTORE: Mon Apr 25 10:52:47 2016: Begin level 0 restore
Ndmpcopy: fas01: Log: DUMP: 333 KB
Ndmpcopy: fas01: Log: DUMP: DUMP IS DONE
Ndmpcopy: fas01: Log: DUMP: Deleting "/vol/vol1/../snapshot_for_backup.1" snapshot.
Ndmpcopy: fas02: Log: RESTORE: Mon Apr 25 10:52:47 2016: Reading directories from the backup
Ndmpcopy: fas02: Log: RESTORE: Mon Apr 25 10:52:47 2016: Creating files and directories.
Ndmpcopy: fas02: Log: RESTORE: Mon Apr 25 10:52:47 2016: Writing data to files.
Ndmpcopy: fas02: Log: RESTORE: Mon Apr 25 10:52:47 2016: Restoring NT ACLs.
Ndmpcopy: fas02: Log: RESTORE: RESTORE IS DONE
Ndmpcopy: fas02: Notify: restore successful
Ndmpcopy: fas01: Log: DUMP_DATE is '5756548862'
Ndmpcopy: fas01: Notify: dump successful
Ndmpcopy: Transfer successful [ 0 hours, 0 minutes, 5 seconds ]
Ndmpcopy: Done
fas02>

 

I have created a volume vol1 on fas01. I have created cifs share called share1 on fas:/vol/vol1. Similarly i have created share1 on fas02:/vol/vol1. I have plaed a file on fas01:/vol/vol1 and copied to fas02:/vol/vol1 using ndmpcopy. Please find the attached screenshots for outputs.

 

If this solution resolved your issue, please mark it as resolution and give kudos

Tried the user name for both source and destination but facing the same source authentication error when i delete the source  then it prompt the destination authentication error and when i deltee both source and destinatin id in the filer then i am aable to ndmpcopy in the same filer. Please note down that i have taken the above steps in same filer.

 

 

Regards,

 

 

If you are doing ndmpcopy in the same filer you don't need any authentication. You can directly run the ndmpcopy command.

 

ndmpcopy fas01:/vol/vol1 fas02:/vol/vol1 

 

The above command is enough.

 

Note : Please use root account and root password only.

You have to give both source and destinations authuntication on that command. Please find the below command for example.

 

ndmpcopy [-sa <username>:<password>] [-da <username>:<password>] <source> <destination>

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public