Data Backup and Recovery

Change SnapDrive Web Listening port - configure SnapManager for Exchange to talk to alternate port


Snapdrive / SME - doesn't like eVault

We are attempting to install SnapDrive on a 2003 server and SnapDrive is complaining that the Web Service failed to start - The TransportManager failed to listen on the supplied URI using the NetTcpPortSharing service: the service failed to listen.

We've read throught this kb article -

     reinstalled .Net 3.5

     checked user credentials are using domain\username

Turns out - when we stop the eVault service - snapdrive installs and works properly.

Problem is - for now - we need evault.

So we change the SnapDrive Web Listener port from 808 to 4093 - and it works fine.

Now - we cannot get SnapManager for Exchange to initialize - or talk to SnapDrive over an alternate port to 808.

We found 4 config files in the SnapManager for Exchange folder - and found reference to :808 in many places.  We saved an old copy of these files and did a find and replace.  SnapManger for Exchange when through connecting to SnapDrive once and then would not work again.

Has anyone changed the SnapDrive Web Listening port and configured SnapManager for Exchange to connect on this alternate port?





Hi - Moving this thread to our very active Ask the Expert discussion for Exchange & SharePoint.  Our experts are on it!


Thanks so much!
Terri Peluso
Senior Community Program Manager


SnapManager for Exchange 5.0 does not allow the configuration change of the web listener port.  It is 808.

At the time of development, Microsoft released port sharing functionality that we follow because we use the NET.TCP Port Sharing service which is part of WCF.

For more info on port sharing see:

It looks like your vault application does not use the port sharing service.

In a future release of SnapManager for Exchange, the port can be changed.




Which version of SME can we change the port on?


For future reference - SME 6.0 and higher default to port 810 instead of 808, and have the ability to change this port in these registry settings (prior versions were hard coded to port 808):

1. Add the registry String (text) value and set it to new port number:

SOFTWARE\Network Appliance\SnapManager for Exchange\Server\ServerPort

2. In the "config" files in the SME installation directory, replace the default port value (810)

with the desired new port value: