Data Backup and Recovery

SDW6.2/Win2k8 authentication failures - W2k3 AD


Hi all

I have a customer who is having problems with the Snapdrive service not starting.  There are 2 x W2k8R2 servers in a cluster with MSCS installed.  SQL2005 is clustered.  SDW 6.2 is installed, and set up to use a Snapdrive AD account that is part of a W2k3 PDC.  After I installed everything last week, it all worked and failed over.  The customer was seeing problems from Friday whereby the disks were not available to the cluster.  On analysis, it seems that the Snapdrive user is not authenticating with the domain so the service wont start.  The same thing has happened for SQL, and the got around it by setting SQL to use local accounts.  If I try and start the service manually and enter the domain account password, then it starts the service.  But if I want to look at Snapdrive and do anything with disks, as soon as it does anything it tried to authenticate and fails, and the service stops.

I have set it up with Snapdrive using local accounts, and added the same account locally on the filers in the cluster and this works fine now with no authentication failures.  But when its left as Snapdrive using the domain user I get the problems.

I am pretty sure it isnt a Snapdrive problem, but a Windows/AD authentication problem.  Has anyone seen anything similar ?





Kindly look at the following thread: Seems like you might be having similar problems. Create a domain account for Snapdrive and add it to the local administrators group and then change the service to logon with this domain account. That way the acoount should not have problems authenticating with the domain.