Data Backup and Recovery

SME 7.1 not working with Exchange 2013 SP1 CU6




i tried upgrading to SME 7.1 on our Exchange 2013 SP1 CU6, but when trying to configure the Exchange Server in the SME management console using the configuration wizard, it gave an error before the LUN mapping page, saying "Failed to get Exchange information for server" and "The communication object, System.ServiceModel.Channels.ServiceChannel, cannot be used for communication because it is in the Faulted state.".


I upgraded Snapdrive to 7.1, verfied all credentials according to the manuals, re-installed and rebooted multiple times (registry and filesystem cleaned, even tried to rename the existing SnapInfo directory, ...), stopped all other services on the server but without any change...


Every time when trying to run the configuration wizard, the debug log shows no errors, lists all Exchange information and ends with the following lines:

[11/18 12:51:58 155] Exit CSmeCDOExm::GetExchangeStructureInternal 0x0
[11/18 12:51:58 155] Exit CNtapSnapMgr::GetExchangeStructure: 0x0
[11/18 12:51:58 233] Enter CSmeServerBase::~CSmeServerBase ...
[11/18 12:51:58 248] m_ptrSnapShot released
[11/18 12:51:58 248] m_pISnapShot4 released
[11/18 12:51:58 248] m_pISnapShot5 released
[11/18 12:51:58 248] m_pISnapShot6 released
[11/18 12:51:58 248] m_pISnapShot7 released
[11/18 12:51:58 248] m_pISnapShot8 released
[11/18 12:51:58 248] m_pISnapShot9 released


I ended up uninstalling SME 7.1 and re-installed SME 7.0 which is working.


Exchange Server: ESXi 5.5 VM, Windows Server 2012 R2 (with current patches), Exchange 2013 SP1 CU6 - no DAG, single server installation (in co-existence with Exchange 2010), 4 iSCSI LUNs created with Snapdrive (1x Log, 3x Store), System drive and Exchange installation drive on vmdk Disks (via ESXi -> NFS store on the same NetApp)

NetApp: FAS 2240-2 with Data ONTAP 8.1.4P1 7-mode (with complete license bundle)


Anyone else got this problem or even better - a solution?



NetApp Alumni

We are tracking this issue in support and we are currently trying to reproduce the error.

on a clean build of Exchange 2013 and CU6 we are not able to reproduce the problem. Currently applying Microsoft hotfixes to verify if that breaks something in .NET.


I will keep this thread updated with the progress.


NetApp Alumni

We could not reproduce the error with the upgrade workflow.

Looking at the error and the relevant function, we could force the problem in following conditions:


-SME is configured or ran at the DAG level

-one of the following services is stopped or not responding on one nodes of the DAG


Snapdrive Service, Snapmanager Service, Snapdrive Storage Management Service,Snapdrive Management Service.


Would be good if we could get the output of following powershell cmdlet before and after the upgrade:


Get-Service –ComputerName Node1, Node2, Node3 –name Snap*, SDMGMT*, SWSvc



Best regards,




Any update on this issue?


hi having the same issue has anyone find the solution to this issue




check if the service SnapDrive Storage Management Service is started. This has solved my issue.





I'm having the exact same issue running the config wizard.  Slightly different environment.


Server 2012 R2

Exch 2013 CU9

Ontap 8.3 C-Mode

Snapdrive 7.1.1

SME 7.1


Unfortunately I don't have the option to revert to SME 7.0 as it is not a supported configuration.



Anyone able to find a solution for this issue?


any update on this .. I have EXCHANGE 2013 CU9