Data Backup and Recovery

SME error - Incomplete path or invalid location


Anyone seen this - we're getting this after running verification on a recent backup:

Error dialog box:


SnapManager for Exchange

Failed to get Exchange information for Server - SERVERNAME

Error Code: 0xC0040206

[SnapDrive Error]: Incomplete path or invalid location.


Exchange server is up, filer is up, SnapDrive service is running fine etc.

Please help!



To add, also getting this initial dialog box when opening SME:


Failed to verify the Exchange server. Please make sure that Microsoft Exchange Server version 2003 or 2007 is installed in the Server.


This sounds like a permissions issue. Before you get too far what is the version of SME, SnapDrive, DSM, Host Utilities, Exchange and Windows.

Check the permissions on the host system. Login as the user you installed SME with and make sure you can see all of your exchange storage groups. Along with this make sure you have the permissions as an admin for exchange.

Check to make sure your SME service is in the local admins account.

Let me know what you find.


Thx for the reply Rich!

My versions are:

SME 4.0



1 system

1 head

2 shelves

Windows 2003 Server

Exchange 2003

I can log into Windows, open ESM fine and see all SGs, I can log into the filer as well.  The service account being used for SME is a local admin as well.

Anything else I can look at?


To add, I've also tried disconnecting the Exchange server and reconnecting to the SME as well with the same results.


More info, am getting the following in eventvwr:

SnapDrive warnings:

Event ID: 303
Filer does not have a live IP address.
Filer id: ''
Filer host name: 'SERVERNAME'.


SME requires that SnapDrive is healthy. What I mean by healthy is that SnapDrive needs to be able to communicate to the storage controller, the name resolution between SnapDrive and the storage controller is good (both forward and reverse name resolution is preferrable),

If SnapDrive cannot communicate with the storage controller to determine it's IP address, I suggest that you set the preferred storage system IP address in SnapDrive. This is very important for storage controllers with multiple network interfaces. Also, check the name resolution of the storage controller host name from the Windows host and the name resolution of the Windows host from the storage controller. Finally, check to see if the SnapDrive service account is in the local administrators group on both the Windows host and the Storage Controller.



Thanks Mark - is this supposed to be blank?  See attached file...


No, it should not be blank. You should put in the hostname of the storage controller and the IP address of the network interface of the storage controller. You can fill in the fields simply by clicking on them.

What version of SnapDrive are you using?

If you have established that you have good name resolution and you have verified that the SnapDrive service account is in the local administrators group on the WIndows host and the storage controller, you will also need to ensure that the RPC (or HTTP/HTTPS for SDW 5.0 and higher) communication is not being blocked by Windows firewall on the host.

You can either turn off Windows firewall or you can establish exceptions for the SnapDrive service (SWSvc.exe). This is covered in the SnapDrive product documentation.

One way to test to see if SnapDrive is able to communicate correctly with the storage controller is to create a small test LUN.



Mark, putting in the filer name + IP didn't make a difference unfortunately.

SnapDrive version is, FAS270, ONTAP 7.2

I'm able to browese to http://filername/na_admin and create a test lun successfully.


Thanks for the information.

I just checked the NetApp Interoperability Matrix and SnapDrive 4.0 is not supported with Data ONTAP 7.2.

You need to upgrade to SnapDrive at a minimum.

What is the service pack of Windows 2003 that you are running?

What is the service pack of Exchange 2003 that you are running?

What is the version of iSCSI initiator that you are running?



Actually, SnapDrive version is, was confused with SME. 

If we still need an update, our support contract is ended with NetApp with no budget for renewal, can we still upgrade SnapDrive without license etc.?  Another question is, how is it that it's been running fine up to 2-3 days ago?


Windows Server 2003 Enterprise SP2

Exchange Server 2003 6.5.7638.1

The release notes indicate 2.02 (for iSCSI initiator)


SnapDrive 4.2 is supported with your version of ONTAP, so you are okay.

Can you create a test LUN via SnapDrive?



I take it I won't be able to (screenshot attached)?


The error in the picture is that SnapDrive cannot enumerate the snapshots for the LUN. Try restarting the SnapDrive service account on the Windows host.

After that, please try to enumerate the list of snapshots. If you still get the error, please answer the following questions:

1. What is the domain and name of the SnapDrive service account?

2. If the SnapDrive service account is a domain account can you check to see if the account is locked out or if someone has placed restrictions on which computers the account can log into.

3. If the SnapDrive service account is not a domain account, reset the service account password on the Windows host and the storage controller.




I think you pointed me in the right direction, our NOC guys informed us that there was an issue with the DC which is likely the root issue - once they resolved, I'm able to connect to the filer again.

Thanks again for your help!


do you know what was wrong with your DC?  I've been having the same exact issue for over 2 weeks, but don't see any obvious problems with any of my dcs.  Thanks.



I had the same problem, after removing a DC that the filer was using, I had to update and registed the new dc in a CLI of a filer (FAS250).