Data Backup and Recovery

SMSQL mount error on Win2008R2x64. Cannot verify or mount backups.


Is anyone else experiencing this issue?

I have a Windows 2008 R2 64bit server running SQL Server 2008 64bit.

I installed SnapDrive 6.2 x64, SnapManager SMSQL5.0R1P2_x64 and the latest host utilities (netapp_windows_host_utilities_5.2_x64).

The LUN & vol setup is exactly the same as my other "non 64bit" SQL servers i.e. I have 4 LUNs:

- databases

- logs

- snapinfo

- systemdbs

Backing up the databases works fine, but if I attempt a verify or restore it fails whilst attempting to mount the snapshot LUN. I've tried various fixes including re-creating new vols and using SnapManager to re-create all the LUNs, the migrating all the stuff to these new LUNs. I've also re-installed the host utils/snapdrive/snapmanager etc. Still the problems persist.

SnapManager gives the following error:


[SnapDrive Error]: A timeout of 120 secs elapsed while waiting for volume arrival notification from the operating system.

And Windows gives the following strange error:

Log Name:      Application

Source:        SnapManager for SQL Server

Date:          22/03/2010 15:21:59

Event ID:      2360

Task Category: General

Level:         Error

Keywords:      Classic

User:          N/A



SnapManager detected that SQL Server is installed on an unsupported Windows platform.

Platform ID = VER_PLATFORM_WIN32_NT, Major Version = 6, Minor Version = 1

As far as I can see, the versions of SnapDrive and SnapManager that I installed are the latest and do support Win2k8 R2 x64 and SQL 2008 x64.

Does anyone have any ideas?






As i see from ms site SQL Server 2008 support this OS:

Supported Operating Systems: Windows Server 2003 Service Pack 2; Windows Server 2008; Windows Vista; Windows Vista Service Pack 1; Windows XP Service Pack 2; Windows XP Service Pack 3

Platform ID = VER_PLATFORM_WIN32_NT, Major Version = 6, Minor Version = 1 - this is Windows Server R2 version.

Also i cannot find that Windows Server 2008 R2 supported in SnapManager for SQL.

Windows Server 2003 Standard Edition (SP2, x64)
Windows Server 2003 Enterprise Edition (SP2, x64)
Windows Server 2003 R2 Standard Edition (SP2, x64)
Windows Server 2003 R2 Enterprise Edition (SP2, x64)
Windows Server 2008 Standard Edition (x64)
Windows Server 2008 Enterprise Edition (x64)

We do this on Windows 2008 Server and SQL Server 2008 and everything was ok.


SQL Server 2008 supported with Windows Server R2 with SP1


Wow - you seem to be right there. I missed that.

Apparently SnapManager 6 has support for Windows 2008 R2, but I am not sure if this has been released yet!?? - our version of SMSQL (v5) doesn't.

Regarding the SQL Server compatibility, I have checked and SQL 2008 SP1 is installed and IS supported on Server 2008 R2 - so this is at least OK (our installed version of SQL is supported on R2).

Do you know if SMSQL 6 is available anywhere and/or when support for Windows 2008 R2 will come?? I am kind of stuck until this happens.

I can't find anything on the NOW site regarding this.

I think I am going to go and roast my SQL guys for not checking SnapManager compatibility list before they deployed our Sharepoint environment onto this R2 SQL server!!!


The issue is that SnapDrive failed to mount the snapshot.

: A timeout of 120 secs elapsed while waiting for volume arrival notification from the operating system.

Make sure you can mount snapshot from SDW first before trying SMSQL. Do you have MPIO installed? If you are not using MPIO, make sure you don't install it.




Well, i just tried connecting to the snapshotted LUN with SDW, and it also timed out whilst trying to connect the LUN.

This is weird - all the existing LUNs were connected and created using SDW on the server - and they all connected and work fine i.e. I can create (sorry, typo corrected!) new LUNs fine.

But why can't i connect snapshot LUNs?

The MPIO is an option when installing the SDW isn't it?

I am pretty certain that this wasn't enabled during the install - is there any way to easily check this?



SnapDrive - 6.2P1

Date Posted: 12-MAR-2010SnapDrive 6.2P1

Based on SnapDrive 6.2


Bugs fixed in this release:



397424 |SDW: Lun restore fails IOCTL_DISK_SET_DRIVE_LAYOUT_EX on reversed snapmirror destination

382378 |stale entries in reg HKLM\SYSTEM\CurrentControlSet\Services\ontapdsm\Parameters\LUNS\

390915 |SDW Service is dependent on the availability of VMware vCenter Server

393518 |SnapDrive 6.2 fails to create RDM LUNs with ESX iSCSI when FCP license is not set on the filer

393770 |SnapDrive sending an ASUP msg "This volume is not designated for thin provisioning".

395057 |SMHV does not work on Japanese Windows OS

397462 |Windows 2008R2 120s Volume Arrival Timeout when connecting to LUN Clone on the same host

397866 |Snapshot mounts are very slow

398316 |upgrade to main from sdw 6.2 gets runtime error. program: navssprv.exe

Vinh Ho


Great! But where can I find the download on NOW? I can still only see the "SnapDrive6.2_x64.exe".

I believe the "P" releases are only available on request? (I had the same problem with SMSQL - we use "SMSQL5.0R1P2_x64.exe" but only the non P2 version is on the NOW site for download (someone else kindly posted the P2 link. Why NetApp don't publish the P releases on NOW I have no idea....maybe one of the techs can answer this because its sure annoying to think you're using the latest version, then spend hours fixing it only to find out that there is a newer version available!).

This sounds like the bug we are facing though and I need to get a copy of SnapDrive 6.2P1 to see if it helps!




Here is the link.

To access a specific version, enter it here:

Bottom of Form

Vinh Ho


Thanks! Good for testing. Waiting for GA release.


Well, I guess my NOW software site isn't quite working the same as yours because a the bottom of the form I get a useful little drop-down list filled with old version of products (snapdrive 3 etc) - and no matter what I search for I cannot find 6.2SP1!

So thanks for sending me the link!

The guys on this forum are golden. I've been banging my head for ages on this!

I am installing the SP1 now and will let you know if it works.

Thanks, Marc.



In the little drop-down list filled with old version of products:

Select SnapDrive 3.X or Above

Version, enter it here: 6.2P1

Vinh Ho

Professional Services Consultant

PS - North Amer - WestHQ


408-218-4008 Mobile

408-822-4547 Direct


Thank you so much Vinh Ho!!

It fixed the problem.

I can now mount snapshots through SMSQL and SDW (no more timeouts!).

Thank you for pointing me in the direction of 6.2P1 and posting the link! You're a star!

Thanks to the other guys who responded too. As I said, you're all golden and I'd be lost without these forums!