Data Backup and Recovery

SnapDrive Error Trying to Create LUN via iSCSI using Simulator


Hello All,

I'm getting a strange error -- I can create a LUN and share it via iSCSI from the sim, and mount it on my w2k8 box. The LUN actually connectes and I can read and write to it, but it never shows up in SnapDrive. Even when I create the LUN in SnapDrive, it gives the following error message at the end of the creation process:

-------------------------  SnapDrive Operation Start ---------------------------------
Disk Create operation on server - WIN-DDIYQKN2UE4 failed for reason
Failed to get Data ONTAP version running on the storage system simtest.
Error Description: Can't connect to host (err=2).
--------------------- The complete operation list is shown as follows -------------------

********************* Server Name: WIN-DDIYQKN2UE4*********************

1. Checking input parameters
2. Checking policies
3. Turning off snap scheduling
4. Creating the LUN
5. Creating a partition
6. Formatting the disk with NTFS
7. Mounting volume on the disk
8. Failed to get Data ONTAP version running on the storage system simtest.  Error Description: Can't connect to host (err=2).   ...
------------------------------------------ Operation Done ---------------------------------------

The LUN actually shows up as a drive letter on the w2k8 box, but never shows up in SnapDrive. I'm trying to get SnapManager for SQL to work, so this is a  major issue.

Windows Host: w2k8, sp2 beta, x64 edition

SIM Version: NetApp Release

Has anyone seen this before?


Meredith Shaebanyan



I have the exact same problem here.

OTAP version 7.3.1

Snapdrive version 6.0.2

Lun does connect as a drive but not visible whitin Snapdrive.

So far i found no answers on the internet.


Eric de Jonge.


I am having the same problem:

Windows host: W2K8 x64


Snapdrive 6.0.2

Did you manage to find de solution to this problem?


This seems to be a DNS issue.




Name resolution works fine and all other network communications is working flawlessly; it fails with the same error when I try to access the sim via IP Address; how do you figure it's a DNS issue?


A previous response for the same issue below.


All, I ran into the exact same issue last week in a Fibre Channel environment installing the Host Attach Kit on some servers with a NetApp that had been upgraded to 7.3.1, which is the same ONTAP version as the simulator -- so I'm guessing this is actually an issue with the 7.3.1 release, or with software (SnapDrive/Host Attach Kit) created prior to the release of 7.3.1 -- I'm  going to start another thread since I don't think this is SIM or SnapDrive dependant.


Meredith Shaebanyan