Data Backup and Recovery

SnapManager for SQL 5.1P1 SQL Login issue


I am trying to upgrade my server to SnapManager for SQL 5.1P1, from 5.0R1

but after the installation, when I try to connect to the server using the snapmanager console, the login window does nothing

I have configured the server in snapmanager using SQL Login instead of Windows Authentication

When I try to expand the server tree, it asks for a login

I type username: sa

and the correct password

but the login window doesn't closes and I can't access the backup / restore tree

If I disconnect from the server, and re-add it using windows authentication, everything works

I did a trace profile on the sql server while I try to connect using SQL Login on the snapmanager console, and it actually connects, run some scripts (getting the sql version), than nothing

I also did a clean install of SMSQL 5.1P1 on a new server, and the same issue appears

If I uninstall 5.1P1 and reinstall 5.0R1, the issue is solved

anyone has a clue about this?




I am also seeing this issue. Did anyone get back to you since your post? I also notice that if I attempt to login with the wrong user or password, it gives an authentication error. Additionally if I disconnect and reconnect the server the SA login works. Odd, it must me a bug in smsql 5.1x I hadn't tried R1 yet, but from your attempt it doesn't seem helpful.

If a bug report hasn't been opened with support I'll do that and post the bug ID here. Thought I'd see if it had been added first.




Nobody got back to me about this yet

I didn't opened a bug report yet. Please do that. I don't even know how to do it !

I am using windows authentication and it's fine for now. but if there is a fix for this it would be much appreciated

there is a new snapmanager version to download. 5.1P2, but I can't test it. If you can, please do and report here

to download it,  go to, software downloads, and on the bottom of the page select SnapManager for SQL, and type  the version number as 5.1P2

it should redirect you to the download page

see ya


just a shot in the wild, have you tried reinstalling .NET Framework 4.0?

Never had this specific problem but know alot of time this helps.    


I don't even have .NET 4.0 installed... only 3.5 latest service pack

It has been a few months and I don't remember if I tried to reinstall it, but now I don't have the availability to do that...

if anyone else could test this, it would be great


Did anyone at any point run your solution through the NetApp Interoperability Matrix?

If anything from OS to firmware is an unsupported version it could be the cause of any issues you're seeing. Click on "Change" to the right of Storage Solution and select SnapManager for SQL, then enter all the relevant versions and check your compatibility.


Usualy you might habe problems with sql discovery. Its either a firewall issue or you miss the sql 2005 backwards compatibility stuff when using sql 2008 and above.