Data Backup and Recovery

Snapdrive error on SMSQL and SME


I run backup jobs each evening using Snapmanager for SQL and Snapmanager for Exchange. Each of these jobs kicks off a Snapmirror when they are done. I am getting the exact same error in the Application log on both machines:

A SnapMirror update request from source (filer1:SQL_UserDB) to destination (DRFiler1:SQL_UserDB) could not be sent. SnapDrive will retry to send this request.
Error code : Failed to list of licenses on the storage system 'DRFiler1'. Error code: 13011. Error description: RPC Error - The remote procedure call failed. .

The above error will appear and then seconds or minutes later I get this:

A SnapMirror update request from source (filer1:SQL_UserDB) to destination (DRFiler1:SQL_UserDB) was successfully sent.

I have FAS3020's running OnTap 7.3.2. I am running Snapdrive 6.0.2, SMSQL 5.0 and SME 5.0. SQL 2005 and Exchange 2007 both run under vSphere 4.0 update 1 and have LUNs presented to them using Microsoft's iSCSI initiator.

Any ideas?



Does the SME wizard highlight any issues when you run throught the configuration?  (Can run this any time without issue, as long as you do not click finish)

Are you trying to run the verification in the 2nd site against the snapmirror destination?  Does that filer have a valid SME & SMSQL license installed?

Have you configured the 'prefered filer' with the management port IP address, in snapdrive on your verification server?

Hope this helps



There are no errors when I run through the wizard. I verify the SQL snapshot right on the same server, I do not verify the Exchange snapshot. I do have valid licenses all the way around. I do have the prefered IP addresses entered into snapdrive. Just to let you know, I opened a case with Netapp on this and so far they have not been able to solve it in 2 months. I thought somebody here may have experienced the same thing. The latest packet traces show that my SQL server somehow loses connectivity with the filer that houses it luns right when the message to have a snapmirror sent from that filer to my disaster recovery filer is being sent. The connectivity it typically restored within a few seconds or a few minutes and the snapmirror message is sent.


You may have a issue with active/active network teams on the host and filer VIF.  Are they on the same subnet?  If they are, 1st try setting the teaming on the host to standby/failover.



Have you escultated the issue with TSE?  MS will not support your Exchange server if you restore a non-verified snapshot.  Call TSE and ask for the dury manager.  If you get no joy ask for further esculation.  The system does work but you have to quantify the problem for the people on the other end of the phone.



I think this issue is more for Snapdrive then SME/SMSQL.

If I see it correctly you have 7.3.2 as Data ONTAP and Snapdrive 6.0.2. In Snapdrive 6.0.2 licensing is Snapdrive based.

However, with Snapdrive 6.2 licensing is Storage system based. The error you are getting is more for relevant to this scenario.

To isolate the problem, try taking a Snapdrive snapshot manually on those LUN's directly and see if it works.

Best way to resolve it is to open a case with NetApp Global Support.