Data Backup and Recovery

Upgrade Snapcenter failed : SnapCenter Plug-in for NAS File Services is not supported


Hello ,


i'm trying to upgrade Snapcenter Server from 4.1.1 to 4.3.1 but got message "SnapCenter Plug-in for NAS File Services is not supported with this version of SnapCenter " . how to uninstall this plug-in ? 

There is a Linux server , probably configured in previous version  but not used .

I cannot find nothing in Snapcenter GUI .





Could you try from linux itself from cmd line:


Usually here:




Hi , 

thx for your reply .

yes i've tried to uninstall from linux but nothing change , still got the message .

Maybe there are some definitions of this plug-in in the repository  ?




could you try tracing if there is anything still lingering around:

rpm -qa | grep netapp-snapcenter-plugin
rpm -e


[root@xxxxx ~]# rpm -qa | grep netapp-snapcenter-plugin
[root@xxxxx ~]# rpm -e
rpm: no packages given for erase

Ontapforrum may be nothing to do with that linux box (Just listening to my common sense), I have worked with NAS plug-ins  a lot and I know there is 'no physical agent' for NAS backup. In other words, NAS Plug-in is basically meant to backup NDMP data from ONTAP (So the plug-in cannot be installed), actual backup works using NDMP protocol.  I am guessing, this plug-in must be on the SnapCenter Server itself. Could you RDP to 'SnapCenter box' and look for NAS plug-in, if it's complaining it must be there somewhere.


I agree with you , but where ? nothing in the registry .. maybe in the repository ? 


Uninstalling the SnapCenter Plug-in for NAS File Services:


IMP (Interesting bit here) : You must ensure that the "file catalog server" host is up and running. SnapCenter requires one or more Linux file catalog servers in addition to the SnapCenter Server. So, that tells me that - There is a requirement of LINUX box for cataloging NAS data. NetApp storage is required for storing the file catalog data, which is mounted here - /opt/NetApp.

Basically, there are some hints here that we need to look for catalog server on linux (Basically, some services are still used).


These are the ports for for linux box (catalog related stuff):
netstat –anp | grep –E ‘8145|8983|2181|2888|3888’


No harm in raising a  ticket with NetApp while you troubleshoot.