Data Backup and Recovery

an error occurred while retrieving the list of data protection policies

mdvillanueva
2,586 Views

Hello Netapp experts,

I am attempting to configure SnapManager for SQL with Protection Manager. So in Snapdrive setup I entered the machine hosting the Protection Manager and entered a domain credential that has admin rights to the filers. This is the same account we use for Snapdrive service. So in SnapManager I go through the Configuration Wizard and I get the following message:

"An error occurred while retrieving the list of data protection policies"

For another server it even skip the Data Protection setting. What am I doing wrong?

Thank you all.

3 REPLIES 3

jduffy_thales_acct
2,586 Views

Hi,

I had the same problem and it was related to DFM privileges.

If you log in to DFM via a web browser, authenticating as your SnapDrive service account (i.e. the account you configured SnapDrive to use for Protection Manager), do you see your full filer estate and are you able to perform all expected admin actions?

In my case, I had my domain SnapDrive service account registered as a DFM user with GlobalFullControl role, and I could log in but did not then see any storage systems and could not perform any admin tasks. Removing the account from DFM and re-creating it solved the problem for me.

I don;t know why removing/re-adding the account woudl work, but it may be to do with the fact that I performed the initial discovery (with a different account) in DFM after I had added the SnapDrive service account as a DFM user,

Good luck ...

Jon

mdvillanueva
2,586 Views

I have addressed this issue using this KB:

https://kb.netapp.com/support/index?page=content&id=1011361

franja_schmid
2,586 Views

Got the same error as we installed SnapDrive with SnapDriveUser@Domain.com instead of Domain\SnapDriveUser

We then had to reset the user without "@" in

sdcli dfm_config list & sdcli oncommand_config list

> sdcli dfm_config set -host Host -user Username -port Port

> sdcli oncommand_config set -host Host -user Username -port Port

Public