Data Backup and Recovery

smbr restores failing


I have "inherited" the backup restore responsibility for our Exchange environment. It is a large environment, making use of "Snap Manager for Exchange" with "Single Mailbox recovery" to do restores of mail accidentally (or otherwise) deleted from user mailboxes. i have been told this has worked fine in the past.

It sort of works now! However, when I check the result, I find that a percentage of between 3 and 35% of items have failed to restore.The failures are logged as "failed with error 0x80004005"

The above happens when I try to restore straight to Exchange. If the restore is directed to a pst file this problem does not occur (though I got a few errors of a different type). However, if I attempt to merge the data from the pst file back into the Exchange mailbox, the same items which previously refused to restore now refuse to be moved. In fact, they just completely disppear.

I note we are using smbr 4.0. I would try upgrading to the latest version, but I have been unable to find out if we are licensed for this (or indeed where to get it from).

has anyone out these had this type of problem?




I'm seeing that error in situations where files are corrupt or problems with permissions.  The reinstall sounds like a good idea.

You can find your licensing information on the NOW site with the user/pass that was supplied to you.  If you don't have this information you can call 1-888-4-NETAPP and get a hold of the CSR team and request this info.

The software can be downloaded from the NOW site here


Just to round this one off. I managed to get all the licensing side of things sorted out (we bought our copy via IBM so it was more complicated than it should be) and installed smbr 5.0. This solved the problem and restores are working fine.

I still cannot understand the nature of the problem (why version 4 was allowing restore of most but not all messages) but at least i don't have to worry about it any more!



Good concept has been convered regarding PST file and its connections with Exchange server.