Legacy Product Discussions

Change SNMP Community String on FAS2020

Hi All,

I am sure this is really simple, we have a dual controller FAS2020's in an active/active cluster running ONtap 7.3.3. Both controllers have different SNMP read-only community strings defined and I want to set them both the same. Using FilerView I have adjusted the string from 'public' to our desired value on one of the controllers in order that it matches that of the other controller. This appears to work and shows the new value but this does not seem to have taken effect. I cannot connect using SNMP using the new string but the old string is still working.

Do I need to restart SNMP or something similar for this to work? Any suggestions?

Jason

5 REPLIES 5

Re: Change SNMP Community String on FAS2020

You probably do need to restart the daemon.

See 'snmp init [0|1]' in the man pages ...

I hope this response has been helpful to you.

At your service,


Eugene E. Kashpureff
ekashp@kashpureff.org
Fastlane NetApp Instructor and Independent Consultant
http://www.fastlaneus.com/ http://www.linkedin.com/in/eugenekashpureff

(P.S. I appreciate points for helpful or correct answers.)

Re: Change SNMP Community String on FAS2020

Hi Eugene,

Thanks for your assistance, I have attempted this, stopping and restarting SNMP but it does not seem to make a difference. I can only connect using the old SNMP community string and not the new string.

Jason

Re: Change SNMP Community String on FAS2020

Hi,

Did you get anywhere with this? I have a very similar problem with my filer.

I've changed the snmp community string from public to something custom and I cannot connect using the new community string. I can still connect using public.

I have enabled and disabled snmp as well as setting snmp.init to 0 and back to 1.

The filer is a 3020 running 7.3.2P4

Re: Change SNMP Community String on FAS2020

Hi There,

This is the exact same problem as we had, altough on a FAS2020. In the end I actually logged a call with Netapp but they had not come across this issue before. They connected in remotely and did the same as what I had already tried. This included stopping and restarting SNMP as you also mention. Still the same problem. We then removed all of the community strings and then re-added and this just started working, even though I had tried this many times in the past.

Not sure this is going to help you much, it just seems that this started working after removing and re-adding the community strings a few times over. I was never able to establish the cause. Perhaps it takes a while to update after they have been changed and I was too impatient? Would be interested to know if you find out any more on this.

Jason

View solution in original post

Re: Change SNMP Community String on FAS2020

Thanks that was helpful.

It seems that the Java applet in FilerView is not correctly setting the community string though I'm not quite sure why.

I have two FAS3020's in a cluster. I deleted all of the SNMP settings from both of them (using Filerview)

On one of them I then re-configured SNMP using the command line. The filer then began responding on the correct community string.

On the other I configured SNMP using Filerview. Everything looked identical when compared to the working filer in both Filverview and from the cmd line interface. However, it would still not respond. I then used the cmd line to remove the community string (snmp community delete all) and re-add my string (snmp community add ro CUSTOMSTR) and everything worked.

Thanks again.

Tom

Review Banner
All Community Forums
Public