The transition to NetApp MS Azure AD B2C is complete. If you missed the pre-registration, you will be invited to reigister at next log in.
Please note that access to your NetApp data may take up to 1 hour.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Legacy Product Discussions

Problem with SnapDrive 6 and Windows 2008 Cluster (3 Nodes)

Eli_Dezman

Hi all

I have a strange problem , we have a 2 Node Windows 2008 Cluster with SnapDrive 6 working ok

after adding another node (Windows 2008 with SnapDrive) to cluster when i try to "Connect to Disk" or "Create Disk" i got error message "RPC is unavailable"

if i remove one of the Nodes SnapDrive continue to work ok

i opened case on the issue , wanted to hear other users opinion

BR

8 REPLIES 8

dstrebel

We are having the same issue. We cant even get the cluster validation to see the disk. Could you let us know what happens with your case.

Thanks

Eli_Dezman

We solved it

did 2 things :

1.disabled Windows 2008 Firewall

2.removed iSCSI from all hosts (using FC) only

we did both of the things , maybe one of them will also work

i am not sure

good help . email me if you need help

BR

Eli

xyz2000

turning off the firewall for all the machines in the cluster was a quick fix for us too. Ultimately I will configure it according to Snapdrive manual. Thank you for your help

MARK_HODGES

one problem with disabling the Windows 2008 Firewall (at least with disabling the service) is that it also doesn't allow Remote Desktop to be enabled I believe.

Haven't tried disabling it AFTEr enabling remote desktop...

Eli_Dezman

no problem with RDP after turning Firewall Off

parulsel

Hi Eli

am also faced the same issue here,

Server info:

OS : Windows 2008

Snapdrive 6

Snap manager 5

Error : RPC server not available check Dcom ports or Windows firewall while connecting disk in snap drive,


am using 2 servers in cluster mode, act as exchange server. in primary server am getting above error, because of that am not able to take backup & verify in snap manager.


note : firewall service is stop only, not disabled.

Pls help me to sort out of this issue,

sflynn

Hi Mark...

I have the firewall turned off (didn't disable the service though) on all of my Windows 2008 server and I can see use RDP. I forget the order in which I did everything though...but I'm pretty sure I enabled RDP then turned off the firewall...and everything is working nicely.

Just thought I'd share my observations...

Thanks...

Shannon

sflynn

Good to hear that you solved the issue Eli. The Windows Firewall was more than likely the issue you were seeing. Page 55 of the SnapDrive Installation and Administrator guide shows you the ports that need to be opened for normal SnapDrive operations (in case you can't totally disable the Windows Firewall)

http://now.netapp.com/NOW/knowledge/docs/snapdrive/relsnap60/pdfs/admin.pdf

Thanks...

Shannon

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public