Legacy Product Discussions

fas270 not seeing internal disks after shelf removal

romeotheriault

Hello, I have a fas270 with it's 14 internal FC disks. The fas270 also had a external sata shelf connected to it's 0b FC port. Recently we removed the external shelf to move it to another filer. After removing the external shelf we set the terminator switch on port 0b to on and then powered on and started the fas270. It's not seeing any of it's internal disks now.

The shelf speed is set to 1gb, the terminator switch is "on", the shelf id is set to 1.

We've tried powering off completely a few times, reseating the cpu module (per netapp supports recommendation) to no avail.

Any ideas on what's amiss here?

I should add that I'm trying to get the fas270 started only so I can destroy the root volume, the aggregate and then unassign the systems disks before it gets converted into a data disk shelf and moved to a new head.

Any help is appreciated.

Thanks

7 REPLIES 7

Re: fas270 not seeing internal disks after shelf removal

lwei

You can power cycle the controller, and use the console to break into maintenance mode (Ctrl C). From there you can check and assign the disk ownership and recreate root aggregate for vol0.

Thanks,

Wei

Re: fas270 not seeing internal disks after shelf removal

romeotheriault

Hi, Yes, we've completely power cycled the controller and even reseated the cpu module. In maintenance mode the system doesn't even see the shelf, let alone the disks. So I can't assign ownership to them or anything.

Re: fas270 not seeing internal disks after shelf removal

lwei

I'm not familiar with internal shelf config. But just curious, why you set shelf speed to 1Gb, the shelf ID to 1? I would think ID=0 is better.   -Wei

Re: fas270 not seeing internal disks after shelf removal

romeotheriault

The fas270 is really a DS14mk2-FC disk shelf with a cpu module instead of a shelf controller module and can only operate at 1gb. Here is a snippet from the DS14mk2-FC Service Guide:

The 1-Gb loop speed
setting must be used if
the disk shelf is
connected to the
FAS270.

and from the fas270 installtion guide:

Verify that the appliance speed (and disk shelf
loop speed, if applicable) is set to 1 Gb.

Also, the shelf id's only go from 1 to 7. Here is another snippet from the DS14mk2-FC service guide.

Each disk shelf in a loop must have a unique ID. A valid shelf ID is from 1
through 7

and a snippet from the FAS270 installation guide:

Set your appliance ID to 1.

Re: fas270 not seeing internal disks after shelf removal

romeotheriault

Thought I'd update this since we figured out what the issue was. It seems there was a hardware issue with the cpu module. Netapp sent out another one, which saw the disks right away. Bingo.

Re: fas270 not seeing internal disks after shelf removal

DAVEROBERTS

I'm curious how you connected the FAS270 to the SATA shelf, I'm trying to do that now and I can't see the shelf.  I'm going from and ESH2 module in the FAS270 to the AT-FCX module on the SATA shelf.  Did you go right from the head to the AT module? 

Answered this myself.  Works now, minor oversight on my end. 

Thanks,

Dave

fas270 not seeing internal disks after shelf removal

romeotheriault

Hi Dave, you can't have ESH and AT-FCX modules in the same loop. This is most likely why your head isn't seeing the shelf. ESH modules need to be in their own loop and AT-FCX modules need to be in their own loop. So yes, you'd need to connect your SATA shelf with it's AT-FCX module directly to one of the free FC ports on your filer head. (exp. 0b)

HTH's,

Romeo

2021 NetApp Partner Experience Survey
PES Banner
All Community Forums
Public