Network Storage Protocols Discussions

Can't map to a NetApp CIFS share?

vonsnyder

I get a drive mapping error when mapping to a NetApp CIFS server from a windows server or workstation. I think it has to do with NetApp connection to the DCs as shown below.

I ran "CIFS domain discovered-servers show" and the status shows the DC/DNS as unavailable or undetermined for all three protocols. The working lab is embedded below but the production is as described with status set to unavailable and undetermined.

 

 

From the client: We can't sign you in with this credential because your domain is not available
From the server: There are currently no logon servers available to service this logon request

 

My lab with the same server and Netapp storage works fine. Here are troubleshooting steps performed with no issue.

 

"CIFS show" is up, shares are shared with full control to everyone
"CIFS security show" settings are mirrored with the LAB

"CIFS domain preferred-dc show" shows both DC ip addresses.
I created a new CIFS vol with no luck (default settings/security etc)

 

On the windows side:

 

 

- Verbose logging in event viewer shows nothing of interest other than a connection trying to establish then disconnecting.
- SMB2 is enabled on the clients
- Get-smb*configuration settings are mirrored with the lab.
- The clients can connect to each others shares no problem both in different vlans.
- I mirrored all the productions group policies from "Security Options" to the working lab with no changes so I don't think GPO is the issue.

 

I spent two days straight on this before narrowing it down to a communication problem between NetApp and the domain controllers at least I think.  Anyone know how I can troubleshoot connectivity between storage and these DCs or explain why they aren't showing up as OK.

Thanks in advance

2 REPLIES 2

Re: Can't map to a NetApp CIFS share?

Ontapforrum

Hi,

 

Which cDOT version is it?

 

Have you tried this KB, it has number of steps for troubleshooting CIFS access issue, may be worth going through it once.
https://kb.netapp.com/app/answers/answer_view/a_id/1071815
https://kb.netapp.com/app/answers/answer_view/a_id/1070767

 

Some basic standard questions:
1) Ensure AD & Filer time is within 5mnt.
2) Do you have host A record for netapp cifs-server in the DNS
3) Don't know whow many DCs you have? But in the pic, looks like one : 172.23.4.2
Testing : Could you go to that server and disable netbios on DC? Netbios in general takes more than 2 seconds to reply, that could be the reason for DCs not responding in time to storage.

 

Thanks!

Re: Can't map to a NetApp CIFS share?

vonsnyder

Sorry guys I tried to delete this post because I fixed the issue but it disappeared on me. I couldn't even find it for some reason.

 

Basically, someone deleted the CIFS AD account or didn't get migrated during domain migration last year. Someone created a new one but that obviously didn't work so it threw me off. I deleted CIFSs from NetApp and recreated it to create a new CIFS AD account and it started working.

View solution in original post

Earn Rewards for Your Review!
GPI Review Banner
All Community Forums
Public