Network and Storage Protocols

CIFS nbalias not working



I wondered if someone can help shed some light on an issuse that I currently experiencing.

We have Four netapp files, all registered and joined to the domain with a name something like netapp1, netapp2, netapp3, netapp4.

We then have a nbalias like Apple for netapp3, and Orange for netapp4

Last night I moved the shares on netapp03 to netapp01 and also moved the nbalias to netapp01. (I moved the nbalias by deleting the line from the nbalias config on netapp03 and adding to netapp01, then performing a cifs nbalias load from the command line).

After doing the above, I managed to confirm that this looks correct. I have also checked DNS for the alias apple and changed that to point to Netapp01.

From my machine I can ping both netapp01 and apple and they resolve to the same IP address.

Therefore I should now be able UNC browse from my Windows machine and expect to see as follows:

\\netapp01\share - this works
\\apple\share - this doesn't

If I create a new DNS record called TEST and point it to the IP address of netapp01 I can browse and see shares, so it's something funny only happening using the nbalias Apple.

I have a Windows machine with the NFS client installed, if I browse \\apple\ from that I can see /vol/share (plus others).

So from what I can tell it seems that the nbalias is only working for nix clients somehow but the real name of the filer works fine for Windows users.

Any help in resolving this will be much appreciate, I suspect that I will have to do a reinstall of CIFS however I am trying to avoid this if possible as this will be very disruptive to the business.






We had a similar problem after migrating from a 7mode system to cDOT. We tried to flush all sorts of caches on the Windows client but nothing worked, after rebooting the client everything worked.


Can you try to reboot a client?


Kind regards


Hi, thanks for sharing, have tried rebooting clients to no avail.