Network and Storage Protocols

Catalog under Cifs-share that has lost user Everyone?


I have a cifs share that has 3 catalogs inside aka 3 qtrees. One of them has lost the user everyone with full control, so now we can't access this catalog from windows client. Only user SYSTEM is left. Is there a way to add Everone and Full Control to this catalog??

I hope you understand me, I'm new to NetApp, but my NetApp-consultant can't resolve this problem.




I assume you have a problem with CIFS (or "windows" shares) instead of qtrees.

I don't know if you can solve this with filer view of system manager (probably you can) but I think the easiest way to solve this is with the console.

when you're logged-on on the console you type following command:

cifs access [share name] everyone "Full Control"

The correct share name you'll find with the cifs shares command>

I hope this solves your issue


Thx, but we have already tried that.

The problem is that the root catalog aka the share has everyone Full Control. 2 of the catalogs under that root catalog also has everyone Full Control, but the third catalogs only has System as user. We have tried making a new share which points to the catalog directly with everyone Full Controll but we can't access it from windows, it doesn't get thoose rights.

For information theese are snapvaults from another domain, so those users don't follow.

I'm guessing thas user System has no known password, otherwise one could connect as that user and add user everyone and/or administrator?

My thoughts now is that maybe the only thing is to break the relationship and make a new qtree to snapvault to, and a new share of course.