Network and Storage Protocols

Clear showmount -a result


Good day everyone:


I just wanted to know how to remove the not active mount points showing in the showmount -a command. 


The scenario is, in my linux workstation i mounted on our netapp filer:/vol/vol0 using the mount command to upload some firmware then I turned off the linux workstation without unmount the volume filer:/vol/vol0 in the workstation. when i logged in i issue the df command and the filer:/vol/vol0 is no logger showing but when i issue the showmount -a filer it shows that my pc is still mounted on the filer, example output:


linux@linux1 ~/Desktop $ showmount -a filer2
All mount points on filer2:


So my question is how can i clear or flush the mount point with out mounting again to the filer and do the umount command.







Use exportfs- f to flush the cache. Refer

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.


Hi Sahana,


thank you very much for the reply but unfortunately it din't work. after i run the command and do the showmount -a command in the linux workstation the old mount point is still viewable.


How long you are seeing this behaviour? Doesn't the cache disappear after a while? It is supposed to, based on the options nfs.export.****.timeout (assuming this is 7 mode)

Sorry to ask this, but just to make sure that we are not missing any pieces, Did you run the exportfs command from the Client or the Data ONTAP CLI? 

If the NFS export is from a vfiler, you should run this exportfs command through "vfiler run".

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.
Cannot find the answer you need? No need to open a support case - just CHAT and we’ll handle it for you.


hi @georgevj,


Thank you for the reply.  it's been a month when this is observe. these are the value of our nfs.export options

nfs.export.harvest.timeout 1800 
nfs.export.neg.timeout 3600 
nfs.export.pos.timeout 36000 
nfs.export.resolve.timeout 6


I execute the exportfs command in dataontap cli and we don't have any vfiler configured. 


so i'm just wondering, how shoumount -a behave and how can i clear/flush the logs. it is not really an issue but i just want to have a clean logs.  


The showmount commands shows the contents of the rmtab file. In theory, when something is unmounted, the entry should be removed, but it isn't guaranteed and you end up having the stale entries. I don't think there is a way to clean that up - except likely by rebooting or restarting the NFS service. You might be able to manually remove the entries from the file, depending on the version of data ontap, but there would be a concern that the NFS service may get a bit messed up if things were removed that shouldn't have been.


We're running into the same issue, a ton of stale entries in the rmtab that is causing current clients issues.  We've confirmed that some of the entries would have been stale before the last reboot, so that did not clear them up.  Does anyone know if we can simply empty the rmtab file of all entries, and will this affect any currently mounts?


I've same issue today, even i did the exportfs -f still not working, but I just find out in the exportfs the older path still exist.

so need to using exportfs -z to clear the older path, then showmount -e is all good now