Network and Storage Protocols

FTP access to CIFS qtree?

MARC_GALLOWAY

With the security mode set to Unix the ftp, nfs, and CIFS access works fine, but CIFS users can not modify the share permissions and users. By default the shares are set with everyone with Full control this cannot be changed when using Unix security mode.  With NTFS security mode ftp does not work. With the Mixed mode a directory that is used for ftp or nfs is not accessible with CIFS and via versa. The requirement is that files can be ftp and accessed by CIFS users for processing.

Any suggestions on getting FTP and CIFS to work together?

1 ACCEPTED SOLUTION

kumaraysun

Hi Marc

1) Enable the FTP on filer.
2) Enable the anonymous access.
3) Enable the ftpd.anonymous.home_dir to the CIFS path
4) Enable ftpd.anonymous.home_dir to same path as ftpd.anonymous.home_dir
5) Loggin using domain credentials or as user "ftp"

This setting worked for me

Kumaresan

View solution in original post

4 REPLIES 4

lagenevoise

Hi Marc,

Have you recieved an anwer, regarding this question.

I'm facing the same question.

MARC_GALLOWAY

I have not. Sorry.

kumaraysun

Hi Marc

1) Enable the FTP on filer.
2) Enable the anonymous access.
3) Enable the ftpd.anonymous.home_dir to the CIFS path
4) Enable ftpd.anonymous.home_dir to same path as ftpd.anonymous.home_dir
5) Loggin using domain credentials or as user "ftp"

This setting worked for me

Kumaresan

rhideg_linear

Hi,

Marc's answer didn't work for me. (I don't undertand the 3) and 4) because these settings are the same).

However this kb article helped for me:

https://kb.netapp.com/support/index?page=content&id=2013377

  • Adding a usermapping to usermap.cfg.
  • filer> wrfile -a /etc/usermap.cfg administrator <= ftp

I think we should test it.

Public