Network and Storage Protocols

Hidden Folder


Hello All,

We have 1 NetApp box with CIFS in our office here.

It was working allright until recently i found that some of our users cannot see some folders under the shared.

I can see the complete list of the folders in my explorer but not other users. I found that the folders which other users cannot see are comming with a mark looks like the pictures in the attachment and it also has attributes:

Read-Only=Checked    (Set this way)

Hidden = Checked     (its grayed out and cannot be uncheck)

Archive = Checked

I'm just wondering the reason is probably that the folder is hidden - which i never checked it. But it seems that i cannot unchecked the hidden attributes on that particular folder.

I'm just wondering whether any of you guys have the solution for this?




Do you have Access-Based Enumeration enabled on the CIFS share

properties by any chance?


Sent from my iPhone


Thanks for the quick reply,

Apparently, our NetApp box does not have ABE enabled.

Other users still can access the folder using the UNC path or by putting the address in explorer, but they just cannot see it on the list unless they uncheck the "Hide protected operating system files" in the folder option of the Explorer. So somehow the Explorer thing that this folder is part of the operating system files.

Still do know not how to make it appear for the users without modifying the folder option.....


Did you find a solution to this issue?


anybody find solution for this issue?


I'm not sure that icon is related to ABE, the little clock indicates an offline/archived file.  It also could be a securecopy issue - see:

One workaround is to create a new directory and copy the data to that directory, delete the old and rename the new to the old name.


Hi jhubert.

I don't wanna dive into all the Microsoft file attributes and where those can come from, but if you need a great toll to handle those beasts, you may find the attachment useful



Btw.: you can find it here: