Network and Storage Protocols

Jumbo Frames prevents Snap Drive from loading iscsi disks (on HP DL380 G5 with Svr 2008 R2 Enterprise)


Server Setup:

HP DL380 G5

2 x quad core


HP Onboard 2 port Lan (GIG) 1 x LAN 1 x SAN

Server 2008 R2 Enterprise Edition

Hyper V enabled


HP Networrk Config Utility

Snapdrive 6.2P1

Windows Host Utilities 5.3.3508.1105

LAN is sepreate VLAN from SAN

E Drive on HyperV host is the HyperV LUN 250Gig.


After a server reboot the HyperV lun for the guests does not initialise.

If you go to LUN MGT in SnapDrive and go connect LUN it sayss it is already connected!

If you go to HPNCU, disable Jumbo frames and reboot the server it all works and the E:\ LUN connects no problem.

I have also noticed the same behaviour within a VM if Jumbo frames are turned on on the Virtual NIC, reboot the VM and the LUN does not connect. Change the V NIC to Jumbo frames disabled, reboot the VM and all is OK!

Any one had similar issues or can advise on a way forward?

Many thanks



Time to close this one off!

When server 2008 reboots, the Snap Drive service and the SD mgt service need to be restarted otherwise disks do not appear in the SDW Snapin.

1. Stop the SD Mgt service.

2. Restart the SD for Windows service.

3. Start the SD Mgt Service.

Refresh the disks in SDW Snapin and they will appear.

As far as Jumbo frames are concerned, our AV on this server had threat mgt turned on and was scanning all packets in realtime.

Turned off realtime scanning and all worked as expected.

Marking this as answered as it solved the issue!


Glad to hear its resolved and thanks for letting the community know the answer!

NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner