Network and Storage Protocols

Microsoft Office poor performance accessing NetApp CIFS share files


Hi NetApp Experts,


I need an advice regarding the potential reason why Microsoft Office applications are very laggy when they are accesses from a NetApp CIFS share.

The file server is A700 C-dot 9.3P7. The clients are various Windows clients 7-10, 2008-2016, using SMB versions between 2.0 to 3.1.1.

The issue  outline is:

  • Any MS Office file is very slow to open from a CIFS share. It freezes at “downloading: ….. (0%)” and after several minutes it loads the file  from 0 to 100% for seconds;
  • If I open the same .xlsx or .docx with other application (notepad, Libreoffice…) it opens instantly.
  • If the same file is copied locally, it opens via MS Office without a delay;
  • The network speed is OK. File copy operations or opening any other file (e.g. PDF, JPEG) happens without a delay;
  • I tried to open MS Office is “safe mode”, setting the network share as “trusted location”…. no improvement;

Based on the above, can you recommend what could be causing this? I’m particularly interested what operations happened behind the scenes, during the Microsoft Office is frozen at “downloading: ….. (0%)”?

Thank you!



We had similar issue and we enabled SMB 1.0 on the CIFS Share. this solved the issue. 




i would not encourage using SMB1 as the support for it starts to get deprecated by a few vendors (for a very good reason).


i think that there could be many reasons for it to happen. and suggest :

1. Check with new file or check that there are no locks on the file before opening it (locks show -path *file-name.txt* -vserver)

2. If there is fpolicy/vscan - try to disable them

3. If there AV on the client, try to disable it.

5. If you coulden't get improvement from all of these and eliminate the cause - capture a packet trace ( and work with NetApp to analyse it.

Gidi Marcus (Linkedin) - Storage and Microsoft technologies consultant - Hydro IT LTD - UK


Hi  and thanks or the responses,


We still have SMB1 enabled in our environment, we are trying to get rid of it. The complained users are with Windows 7 or newer OS,  so they are using 2.0 or greater.

  1. There are no file locks at the files, which I use for tests;
  2. We use async fpolicy  (to stealthbits server), and I have already tried to disable it. This resulted in no noticeable speed gain. We don’t have AV at the NAS server, only at the client side;
  3.  The AV client is currently under investigation, I’ll try to clarify that;


Hi Team,


Did you get a chance to narrow down this issue. We are also having a same kind of behavior with excel and documents. Infact anything related to files. Open/Save/Edit any action takes forever from the NFS filesystem we are accessed via NFS Maestro.

Interestingly if you copy same files to your local desktop  and open, it is instant. (very fast).


Any help in this regard is appreciated.