Network and Storage Protocols

Monitoring IO with PerfMon


I have recently found that I cannot use my Windows 7 or 2008 R2 systems to connect to my filer via PerfMon to monitor stats like Volumes. When I try on my 2003 server it works ok. Does anyone else have this problem?




I bet this is due to the fact there is no rsh in Win7 and/or W2k8:




Radek - I keep getting unauthorized when trying to view that link. Apparently, I am not the only one.


OK, it is within Sales Engineering Community (for NetApp & Partner SEs) & that's probably why you can't access this.

But I think you should be able to see Daniel's blog:




So I installed Utilities and SDK for Subsystem for UNIX-based Applications in Microsoft Windows 7 and Windows Server 2008 R2 on my Windows 7 PC. I needed to add the following directory to my %PATH%, C:\Windows\SUA\bin, since it contains all of the *NIX utils such as awk, grep, and . . . RSH. So now, when I open a command prompt, I can use RSH. So now, for example, I can do this:

rsh -l username:password filer version

On the other hand, when I try to now run perfstat I always get the message "RSH to filer myfiler fails! Quitting." I wonder if the app is looking for something other than just the rsh executable. Has anyone at NetApp ever tried this before?

Thanks for the link to the community site page I am able to see. I already knew about using plink in the past, and pretty much did the same, whereby I added plink to my path. Plink though gives me the same problems as above though, since I cannot run PerfMon or perstat with Plink. It just cuts short the installation of the Unix utils and adds a more secure layer of SSH connectivity.


I have read a bunch of posts on the issue of using perfmon and Windows 7, but have not seen any answers.  Does anyone have Windows 7 running perfmon polling NetApps? 



hi - did you find a solution yet?

since neither rsh nor ssh is used by w2008-perfmon i wonder why everybody suggests installing unix-tools... i did, rsh is working fine - but perfmon not.

I took some wireshark-traces, perfmon uses smb/rpc.

i disabled smb v2.0 on my w2008-server - no success

i enabled smb v2 on my filer - no success

using w2003 perfmon discovers all entities to monitor - immediatly...


Still never found a solution as of yet.



You've probably checked this already...

After receiving "RSH to filer myfiler fails! Quitting." error message once, I checked /etc/hosts.equiv and found that only "Admin" was allowed to establish connection from that particular server's IP address. So, I added the account that I was using to log on at the time and was instantly granted access.




there is no "rsh fails"-message on my site since perfmon is using no rsh at any time, isn't it!? _> 100% SMB/RPC!

No ansewer yet.  Opened a case with NetApp, but they have been no help...


can be this option which is new from 7.3.3:


I ve set it to: options cifs.perfmon.allowed_users everyone


The perfmon_allowed options seems to go away in 7.3.6. 

As far as Windows 7, Netapp claims it is a MS issue.  Interesting to Note that for an XP workstation,  DOT 8.1 perfmon  is sorta broken where it worked on DOT 8.0.