Network and Storage Protocols

Problem with ftp configuration (ftpd.dir.restriction)


Hi, we are trying to configure our vfiler to allow users log-in over FTP if they have CIFS access, but we don't want allow them to access their home directory, but the tree from one directory (/vol/vn25_atlas_data1/data/data/Kannat/Digipiirturi) and to all subdirectories if the user have NTFS rights to access such directory. What I have got from documentation, this should be enough, but it is still not working:

vn25@toaster> options ftpd
ftpd.3way.enable             off
ftpd.anonymous.enable        off
ftpd.anonymous.home_dir          anonymous
ftpd.auth_style              mixed
ftpd.dir.override            /vol/vn25_atlas_data1/data/data/Kannat/Digipiirturi
ftpd.dir.restriction         off
ftpd.enable                  on
ftpd.locking                 none
ftpd.log.enable              on
ftpd.log.filesize            512k
ftpd.log.nfiles              6
ftpd.tcp_window_size         28960

when user try to log-in with his CIFS account he will get following output from FTP client

ftp> open atlas
Connected to ATLAS
220 vn25@vn25 FTP server (NetApp Release 7.2.3: Thu Jul  5 09:51:46 PDT 2007) re ady User (ATLAS:(none)): netti\Digipiirturiftp
331 Password required for netti\Digipiirturiftp.
530 Login incorrect - User has no home directory.
Login failed.

Do you anyone have a clue where a problem could be? Thanks in advance for any ideas.



You need to ensure that the user in question can access each directory in your override path.  If he gets permission denied down any of those paths, that could case your issue.


It seems to me that we have too old version of Data ONTAP to just use

ftpd.bypass_traverse_checking on

is there any equivalent of that option in Data ONTAP 7.2.3, or we just need to add (X)traverse rights to every directory in that path?


If that option isn't in your option list on your version of ONTAP, then I don't know of another way to do it on the storage side.