Network and Storage Protocols

Read-only access to ETC$ CIFS share



We have a client currently running Data ONTAP 7.2.7 and is looking to upgrade to 8.0.2.  Unfortunately, when we attempted to send the appropriate file to the software directory in the default ETC$ share, we encountered permissions issues.  Even when using either a local and then domain administrator account, we could browse the CIFS share but when we tried to save fiels we encountered an error telling us that we did not have permissions to do this.  Oddly, we could CREATE a new text file, but it would be empty -- any text we attempted to save was ignored.  We could also create a folder, but were unable to save any files to that folder.

We tried opening the CIFS share to all domain users, but encountered the same issues.  We also added the domain admin to the permissions tab through Windows, then gave that user ID full access and mapped a drive using that user name, but still no luck.  Any time we attempted to save a file we received a Permission Denied error.

We double checked, and the ETC$ share is set up as NTFS, so we should be able to manage permissions from the Windows side, and we were attempting to manage these through XP, not Windows 7.

Can anyone tell me what I'm missing here?

Thanks in advance for any ideas.



You can verify qtree security /vol/vol0 has unix security style and options wafl.nt_admin_priv_map_to_root on



I would try adding a new share and try to access it from a windows client

>cifs shares -add  rootshare /vol/vol0

>cifs access rootshare everyone full

Once the file is copied remove this share as it has everyone/full access.



Thanks for the replies.  Both suggestions were useful though the answer was not actually related to either.  The client is running Windows 7.  When they ran Windows Explorer as an administrator, they were able to save files to the share.

Thanks again.